Grasshopper Installation Problem


#1

Hey there. :smiley: I’m trying to use the Grasshopper plug-in for my Rhino version 5.0 but every time I try to install it it says that it isn’t compatible with the Rhino Installer Engine. I’m not very good with computer coding either so if someone can please explain to me, in understandable terms, what I should do to make this work, it will be really appreciated. I need it in order to experiment with inflatables and as my deadline is coming up, a quick response will be amazing. Thank you for reading this! :smile:


#2

This issue came up with older revisions of Rhino5. Are you updated to the current SR?


#3

No, I didn’t know that there’s already a latest version. What is the latest one?


#4

Current is SR7. You can check for yourself: go to Help menu -> check for updates. Make sure, updateing is enabled. then click “check now”


#5

I’ve updated it and tried to load Grasshopper again by dragging the file into the viewport but I still got the incompatibility results. I tried to load via the plugin manager as well but to no avail. Do you have any other solutions?


(Wim Dekeyser) #6

In October, @brian wrote:
you likely have a corrupt RHI file. Please delete it and download again and see if that fixes incompatibility error.


#7

Normally it’s a real installer, just close Rhino and then double click on the Grasshopper installer file. The install dialog should pop up.

Is your Windows up to date (dot net 4, etc…)?

–Mitch


#8

I will try that, thank you.


#9

My Windows is up to date. Could there be another problem?


(Pascal Golay) #10

I’d make sure rhi files are correctly associated (in Windows) to the rhiexec.exe in the Rhino installation folder > System > X64. You can do this via a right click > Properties on the rhi file - look for ‘Opens with’ and Change.

-Pascal


#11

What File extension do you have on the installer?

Is it RHI or ZIP?

If it is ZIP this is due to your browser renaming it when you download.

If this is the case, you can go to the Folder settings of Windows Explorer and un-tick “Hide Known File Types”. This will allow you to rename the extension from .zip to .rhi. Then simply double click on the file to launch the installer.


#12

The file is a RHI file. I have already tried to run the installer but it doesn’t work. Thank you for the suggestion. :slight_smile:


#13

I uninstalled my Rhino according to wim’s suggestion and am reinstalling it now so I will make sure to check that when I try to reinstall Grasshopper, thank you. :slight_smile:


#14

Grasshopper is distributed as .RHI, which is basically just a zip file with the extension changed.

So there really are just the three failure scenarios @dannyboyesiom, @Pascal and @wim mentioned:

  • corrupt RHI/Zip file
  • corrupt file association
  • corrupt Rhino Installation

If all fails, you can just

  • rename the RHI to zip
  • create a subfolder in the Rhino plugin Folder
  • extract everything to this Folder
  • drag/drop the GrasshopperPlugin.rhp into Rhino

#15

Thank you so much everyone. :slight_smile: I suspect that it was due to the corrupt Rhino Installation. I reinstalled Rhino and I was able to install Grasshopper. Thank you again!