Grahics performance is really bad


#1

I’m sure this has been brought up before but I’ve been testing the WIP a little bit and it’s literally unusable on a generic dell workstation with a entry level nvidia card which I imagine is a very common setup. Maybe its not— i’m sure you guys have the statistics and maybe you’re targeting gaming cards for whatever reason. But even the basic shaded mode is useless which means there’s no point in testing the application until this is fixed.


(Wim Dekeyser) #2

You will have to provide more information about your system. For starters, can you post a screen shot of your OpenGL settings? That is found here: Rhino Options > View > OpenGL


(Steve Baer) #3

We actually are not aware of this. If you could provide the OpenGL options page details that would help


#4

Rhino’s rendered mode is close to unusable on a macbook pro running Windows, i7 gtx 770m retina setup too. It’s just too many pixles, so it needs a 1/2 and 1/4 res option. Same goes for raytraced mode, just too many pixles.
On my workstation with a 1070 and a 27" 2560x1440 monitor it is nice and smooth though and it looks great though.
Ps, I had to ditch my old macbook with windows, i5 330m setup because of this. It worked great on V5 but was useless with v6.


#5

NVIDIA Corporation
Quadro K600/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 377.11
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 3-17-2017
Driver Version: 21.21.13.7711

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB


(David Eränen) #6

Hi arch,

Are you saying that starting Rhino and making a sphere, then switching to Shaded mode makes the display unusable?

-David


(David Eränen) #7

Holo,

I can see that here also. We might have to lower the number of samples or the resolution of the skylight shadow effect on laptops with retina/4k screens.


#8

Hi David, lowering the resolution for the viewport would be much more preferred for me as that would affect all display modes both now and for the future. In example I could easily use a 1280x720 interpolated resolution for a maximized view to evaluate a design, and then switch to 4k when lighting and camera was set up and I. In other words I would in some situations prefer good quality and low resolution over low quality and high resolution.
Hope that makes sense.


(David Eränen) #9

Holo,

I am wary of resorting to downgrading the viewport resolution. If the skylight shadows are solely responsible for the slowdown on high-resolution laptops then I think we should fix the shadow algorithm, not downgrade the viewport resolution. What I would be open to is to downgrade only the shadow resolution, like we do already in dynamic mode. Skylight shadows usually vary very slowly across the screen so the resolution downgrade won’t be as noticeable, especially on high-resolution screens.

Another fix would be to decrease the radius.

-David


#10

So if I get you right the shadow resolution is controlled by the viewport resolution? I thought it was static and independent of viewport size.
Glad you’re on it!


(David Eränen) #11

Holo,

The soft skylight shadows are calculated in screen space, i.e. per pixel. The sharp shadows that are cast by the sun or e.g. a point light are independent of pixel resolution.

-David


#12

Got it, thanks!


#13

Yes, I had to disable a bunch of plug ins to get somewhat manageable and even now, if you actually load a working model and not just a couple spheres, it’s so slow compared to rhino 5. I understand the rendered and arctic modes are new so it’s not fully polished but why is the shaded mode slower than the older version?


(David Eränen) #14

arch,

Do you have any models to share that I could test with?


#15

I can’t share the models I’m using because I don’t own the content and I don’t have a personal rhino license either. I use rhino at work.