Display Viewport Rendered Mode (Bug)


I have noticed a shading bug in WIP when viewing objects in the elevation views; front, right etc. in Rendered mode. Shaded mode seems ok.

That’s a cylinder.

The shading appears rough. When I import the same object into V7, it looks smooth, as expected.


Rhino 8 SR0 2023-3-28 (Rhino WIP, 8.0.23087.12305, Git hash:master @ 308b13bf3b25029740e667ceba72704a53adf6a5)
License type: Commercial, build 2023-03-28
License details: Cloud Zoo
Expires on: 2023-05-12

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Unplugged [81% battery remaining] ~140 minutes left

Hybrid graphics configuration.

  • Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 8-4-2022 (M-D-Y).*
  • Integrated graphics device with 4 adapter port(s)*

  •    - Windows Main Display is laptop's integrated screen or built-in port*
  • Primary OpenGL: NVIDIA RTX A1000 Laptop GPU (NVidia) Memory: 4GB, Driver date: 8-22-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.13*
  • Integrated accelerated graphics device (shares primary device ports)*

  •    - Video pass-through to primary display device*

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)*
  • Anti-alias mode: 4x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: High*
  • Vendor Name: NVIDIA Corporation*
  • Render version: 4.6*
  • Shading Language: 4.60 NVIDIA*
  • Driver Date: 8-22-2022*
  • Driver Version:*
  • Maximum Texture size: 32768 x 32768*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 32768 x 32768*
  • Total Video Memory: 4 GB*

Rhino plugins that do not ship with Rhino

  • C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\\KeyShot7RhinoPlugin\Rhino 5.0\KeyShot7RhinoPlugin.rhp “KeyShot7RhinoPlugin”*

Rhino plugins that ship with Rhino

  • C:\Program Files\Rhino 8 WIP\Plug-ins\SolidTools.rhp “SolidTools” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement” *
  • C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.23087.12305*
  • C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”*

remember a hybrid laptop unplugged will keep trying to use the intel to save power.

run plugged in and check out this thread-

Thanks Kyle,

It happens in both plugged-in and battery power modes…

But this is not a problem in V7; it smoothly renders, with the same laptop. I’ve tried a couple of different files and compared between v7 and v8 and they exhibit the same behaviour…

Any other idea why this could be happening?


@theoutside Kyle, Do you have any other suggestions about this?


let’s try updating nvidia and intel drivers.

update nvidia from their website, and install it custom/advanced and use the clean install checkbox.

for the intel use this tool-

Also might not hurt to make sure the display mode you are using has been reset to defaults