GH-Tekla Improve item precision

Hi everyone,

I am using Tekla LiveLink in order to import complex geometries in Tekla. However, the level of precision of the resulting items is bad. It seems as Tekla triangulate the items with a coarse approximation…I have tried to use the SMOOTH tool we have on the ITEM tool provided by Tekla, being the result better but not still good. Do you have any tricks to solve that?


Hi @bbalbastre ,
Try setting ‘Smooth_lines’ settings to “True”.
If that does not work, I think you can’t solve the issue. Tekla probably meshes Rhino’s brep, and beyond access to local “Smooth” component property, meshing can’t be controlled.

Hi djordje!

Thank you for your answer, the quality of the model improve a lot.

Regards :slight_smile: