DWG to Rhino/GH to Tekla Profile - arc not showing smooth

I’m excited about using GH to manage Tekla profiles created from dwg geometry, but I can’t overcome one issue.

Workflow:

Insert dwg to Rhino (Embedded and Linked)

Create surface from planar curves

Create Profile in Grasshopper using surface

The problem is that the smooth arc on the surface turns into lines when I reference the surface in Grasshopper when creating the Tekla profile. See images



Assigned to Tekla category.

Hello,

Are you sure this is indeed an approximation and not just the model view of Tekla that facets everything ? You can check the profile contour points definition I think.

Also If I remember correctly the Profile component only work with arcs or lines, not generic NURBS, so maybe a Simplify Curve is needed.

I’m surprised the component works with a surface, I used to provide the outer boundary in O and the inner boundaries in H.

1 Like

I tried Simplify Curve, that didn’t change it
I created a drawing to show that its not just the model view
the Rhino curve looks smooth and i changed the GH definition to reference curve instead of surface, same result


Can you upload your Rhino file with the curves ?

Maybe @sebastian.lindholm can have a look at this.

1 Like

i’ve got the same post in at Tekla Discussion Forum, but here are the files
profile_smooth.3dm (887.2 KB)
profile_smooth.gh (5.0 KB)

@magicteddy what is the Profile Contour Points definition?

In Tekla Structures, when you create a custom profile you have a window (that also opens shortly when using the Profile component) where the list of contour points is stored. This could be a way to check if the arcs were correctly created, but the section drawing is another good way to check.

I looked at the file, using either _SimplifyCrv in Rhino, or Simplify Curve in Grasshopper then Explode, I was able to check that all segments are arcs or lines, which should be correct. Unfortunately I don’t have a Tekla licence so I can’t be more helpful there.

1 Like

Snag_55cfa2d
this may be obvious, but Tekla doesn’t like the chamfers for some reason. hoping there is a workaround that may involve some rework of the dwg linework prior to bringing into Rhino

after playing around with simpler curved profiles and more complex linear profiles, i believe the issue lies in the profile only being allowed a max of 99 chamfer point definitions, which forces some arc points to be defined as linear if there are too many arcs in the profile.

@sebastian.lindholm is there a way to increase the number of chamfer points allowed to be defined by a profile, or are we stuck with breaking larger, more complex profiles into multiple smaller ones?

Better yet, is there a way to have Tekla import the profiles with arcpoint chamfer definitions at the arcs instead of breaking the curves into smaller pieces (which adds dozens of extra points and forces over the 99 limit) and using rounding chamfer points like it seems to do currently?

Has the “Edit polygon cross section” macro that is called by the grasshopper definition been updated since Tekla 2017 in order to allow the increase from 99 points to 999 points?

Hi Forrest,

Here’s an update that allows you to set the max number of control points by right-clicking the Profile component:

https://drive.google.com/drive/folders/1vxeaEaDIZtSp2Ey1-54Ezs1-oPbcZxNn?usp=sharing

pic:
image

The scroller isn’t very responsive since adding a profile is so slow, but you can double-click it to enter a numerical value directly.

This option should really have been enabled earlier as it’s already available for e.g. Beams.

Let us know if it solves anything. Getting the arc segments as arcs would be more ideal of course, that’s a bit more involved however so I put it on the list to investigate a bit more.

Cheers,

Sebastian

3 Likes

This worked perfectly. Thanks @sebastian.lindholm
This will be a game-changer for our firm

1 Like

@sebastian.lindholm It seems we have found a limitation for using this tool. Since it creates all control points as rounding chamfers, even sharp corners appear rounded in 3d and don’t show an edge. This prevents the corners from showing their edges where we would like them to be shown, such as in elevation views in drawings. We could use cuts as a workaround, but this would get cumbersome if we wanted sharp corners at protruding geometry. I’m hoping your team can explore updating the tool to use corner chamfers at sharp edges in addition to arc points at radial curvature geometry.

Hi Forrest, sorry this was a bug introduced when allowing for more points in profiles. It’s been fixed in the update here:

https://drive.google.com/drive/folders/1vxeaEaDIZtSp2Ey1-54Ezs1-oPbcZxNn?usp=sharing

Cheers,

-b

3 Likes

Fixed! Thank you for your magic once again @sebastian.lindholm

2 Likes

@sebastian.lindholm the profile tools have been super helpful on our current project, but getting arc segments as three-point arcs with an “arcpoint” defined middle point would really push it to where we would never use the sketch editor again. An example of where this would be most useful is when a complex profile was previously drawn in the Tekla sketch editor and a small change needs to be made. The change is an opportunity to extract the profile (using Deconstruct Beam and Profile Contour tools) to Rhino linework and re-import the updated profile to Tekla using GH. Right now if you extract a profile using GH, it comes into Rhino without arcs. The arcs need to be redrawn in Rhino prior to re-defining the profile. I’m not sure if the functionality in the profile extraction code is same as profile creation code, and if a solution for one also works for the other, and if it also works for any other curved geometry tools in the Link where curves are broken into lines. That being said, these things are always easier to ask for than to actually accomplish, but you’re the guy for the job. I’m certain of that.