Generic models not appearing in Revit project

This was working but it is no longer working. I’m not sure what changed.

Hi ct.rhino, I changed the forum category to Rhino.Inside - Revit (there are other Rhino.Inside implementations)

Hard to say from the image, the black components indicate they did run. Please check that your Rhino and Revit are working in the same units.

Another thing to check is if the Elements are being placed on a Phase that is visible

I checked the phase filter and the units. I also tried creating a new Revit project and have the same issue, part of the script which imports lines as generic models and masses works but the polysurface generic models no longer come through. I’ve tried amending by duplicating and renaming layers.

One weird thing was that the “commercial” layer was still conveying correctly and I noticed that category was set to null so I switched it to generic model and then the conveyance stopped.

I solved this by creating a family component instead of loading straight to the model.