Fonts No longer Working / Changing Sporadically

For some reason, after a long run with no issues, the last updates to RH6 have been making fonts in Rhino not function correctly (among other things, but I’ll post those separately). For example, I’ll import a template file I keep for documenting architecture projects. After, When I go to add additional text to a dimension, the font will show up as something else other than what I have listed as the default annotation font… and the font that’s listed in the properties drop down. I tried to find a work-around by using existing imported text that’s already displaying correctly, but when I type over the old letters the display text is still wrong. I don’t even know what font it’s substituting because i’m told that what i’m looking at is the correct font.

I don’t pretend to understand what problems the updates to Rhino are addressing, but in my personal experience RH6 is developing more problems as I keep up with the most recent releases.

I’ve tried every graphics driver under the sun to make sure none of the various issues I’m having are related to my GPU with no results.

Any help would be greatly appreciated.


Fonts are seeing a lot of development churn currently.
I’m not surprised you’re seeing issues.
I’ll check in with the developers to see if this is a known issue.

Ok thanks, the font swap happens for every dimension now. Also, this happened around the same time draw order (back or forward) stopped working. Any relation or work-round for that issue?

I can see from your post that there are some problems with your dimensions.
As usual, it’s not as simple as it may seem.
To figure out what’s happening I need to know the specific version of Rhino - The best is to include the first line from the output of the SystemInfo command.
And a file that shows the problem and instructions of how to reproduce it.

@lowell I attached the file with a few elements exhibiting the issue. Just type in any of the selected items (dimensions, font, leader) and it should reproduce the issue.

font_problems_among_other_things.3dm (642.8 KB)

@jtrudeau: This is probably pretty important to Lowell. It’s also available on the “about” page.

Sorry @lowell i forgot to include the Systeminfo. See below:

Rhino 6 SR10 2018-10-6 (Rhino 6, 6.10.18279.17351, Git hash:master @ dcc8b4dc1c0590dc372722e624f0f6b1407e1469)
Licence type: Commercial, build 2018-10-06
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 7 SP1 (Physical RAM: 64Gb)
Machine name: WINTERMUTE-PC

GeForce GTX TITAN X/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 397.93)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18279.17351
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18279.17351
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18279.17351
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18279.17351
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for the heads up @AlW

Got it. Thanks

Hi @lowell any info on the font issues I was describing?


We’ve made quite a bit of progress and are still working on it.
Editing text and dimensions that use Klavika font still doesn’t work right.

Thanks @ Lowell, I’ll keep my fingers crossed or resort to using another font. I do remember Klavika not working during the WIP , then the problem being corrected after the official release.


I just heard from the guy working on the (hopefully) last part of this.
He expects to have a fix in the next day or so.
It’s also a problem with some other fonts, notably Arial Narrow.

Great, thanks for keeping me updated. I switched to a different font for the time being. I’m going to send it to you, if you don’t mind (or have the time) would you mind checking to see if it’s also a cursed font?


Is that real or are you just trying to make me cry?

I looked at your Kakadu font this morning. I don’t know if I’d go as far as cursed, but it doesn’t work very well in Rhino.

Ha @lowell , sorry I have bad taste in fonts.

I can try another font as well and cross my fingers/toes. Sooner or later you’ll find out that I purposefully look for the most difficult fonts with the sole purpose of driving you guys crazy.

Do you think it’s the formatting of the font that’s effecting Rhino? (TTF vs OTF).

If the 3rd font I pick doesn’t work I’m switching to Papyrus and calling it a day.


I should have also guessed a font called Kakadu may not be the best choice.

Those two fonts work right in Microsoft based stuff. They are undoubtedly legal fonts, but just with some things done differently than “standard”.
It’s a long story not likely to be told the same by two people, but we’re struggling with this stuff in V6 as we try to make Rhino work on both Mac and Windows
I do have confidence in the thing with Klavika names changing being fixed soon.