Flamingo Library and Mapping issues


#1

Hi there,
I´ve got some problems with the flamingo-procedural materials. Some of them will be rendered with texture but most of them don´t. Instead they are rendered with their basic color information. In an earlier topic was written that in the folder “…Flamingo nxt/Resources/Bitmap/” should be the .jpeg or .png files. But my Folder is empty.
Rhino basic materials works in viewport and getting rendered.
The problem with both kinds of materials (Rhino and Flamingo) are that the mapping size wich is shown in Viewport don´t match with the result of the rendering.
I use Rhino 5 SR13 64-bit (5.13.60913.21340, 13.09.2016) and Flamingo nxt (5.0.16179.14183, 11.Dez.2016)
For better understanding I´ve attached some screenshots. I hope you can help me to solve that problem!


(John Brock) #2

@scottd
Did you see this?


#3

Hallo John,

thanks to forward my problem.
I have solved the problem with the Flamingo materials with installing the flamingo nxt 2014 first! I had just installed flamingo nxt 5. After installation I could add the …\Resource\Bitmap Folder with the 84 picture files to Flamingo nxt 5.

But the scaling problem with Rhino Materials are still exists (to see in the screenshot). Maybe its an easy one to solve this because of an user mistake…

Kind regards,
Martin


(Brian James) #5

This is caused by nxt 5 not taking into account the texture’s tiling amounts within the Rhino basic material as well as the texture mapping method for the object and it’s tile values. To fix it, change the texture’s tile amounts to 1 in the texture settings within the material by clicking on the texture name in the material editor and navigating to the mapping section.


Then adjust the tiling only in the texture mapping settings for the selection after assigning a mapping method via Properties>Texture Mapping.

Alternately, you could make a Flamingo Textured material which will not have the same issue the basic Rhino material has at the moment. I’ve filed https://mcneel.myjetbrains.com/youtrack/issue/FL-6189 as well to hopefully fix this.