Flamingo 5 Materials issues

I have Flamingo 5 and Rhino 5x64 set up on a testing computer. I have tried updating a real project that was set up with the current shipping version of Flamingo nXt.

The materials are not translating very well and I am particularly challenged by getting them scaled properly to the objects. I REALLY liked the way Flamingo scaled bitmap materials by size and hate trying to scale using the repeat spinners. This one function will keep me away from the upgrade. Is there any chance the material scaling can be made to work the way it did previously?

Also having a tough time getting the U-V orientation of materials the way I want it. Assigning materials by layer is a disaster in that regard. The bitmaps flip and flop in totally unpredictable ways per my understanding and experience.


Robb -

Can you send me an example? In general the materials should still scale by size. But, there are now combinations of mapping that may get confused. I would like to look into that.

The new Flamingo uses Rhino mapping tools and not its own. This removes a layer of interface, but makes translation from the old version difficult if both mapping styles were being used. For instance ins a situation that both Flamingo and surface UV are being used at the same time.

Send me an example and I will see what we can do.

OK - I have now spent more time working with a complex model and a group of about 20 materials that were set up and working well in nXt version 3.1.2014.422. I went back to my primary machine and cleaned out the model of all Flamingo & Rhino materials leaving everything with the default Rhino material. I then loaded the model back on my test machine with nXt 5 and brought in the .ArMaterial s from a folder.

When I assigned materials by layer a lot of them worked well and scaled properly. I like the interface and think that the control panel is good. It was slow on the test machine and the icons did not update properly.

It seems that the problematic issue is related to blocks. I have blocks and nested blocks with many layers involved. The materials are all assigned by layer and within the blocks do not respond to any scaling efforts. It seems that when I explode the blocks and adjust the scale the materials respond appropriately. The attached image demonstrates this with the seat on the left composed of the blocks and the one on the right with those blocks exploded. The same material applied via layer in both cases.

A different issue seems that Images get juggled within the material definition. I have materials set to embedded but when I just now opened the file 2 materials were using images from other materials - visible in the render as well as material panel.

Happy Sweet '16

Robb -

Can you send me the file? I need to check the scaling and the mapping information on the blocked objects.

Is just the chunk illustrated above OK or do you want the whole model.+ ArMaterials folder?