Material library not working properly


#1

sample.3dm (49.7 KB)

Preview from flamingo library is not matching rendered result. In the example above I only applied material to layer.
Any ideas how to fix this?


(Brian James) #2

Thanks, I filed this as bug https://mcneel.myjetbrains.com/youtrack/issue/FL-6186 it seems the texture map got lost in the update to Flamingo nXt 5.0. I found the texture in the Flamingo nXt library though and will attach it here for you. Thanks for the report.


(John Morse) #3

Hello,

I have looked at the Flamingo startup code and discovered that Flamingo attempts to create a resource directory here “C:\ProgramData\McNeel\Flamingo nXt\Resources” then copy bitmaps from a folder in a location similar to this “C:\Program Files\Common Files\McNeel\Rhinoceros\5.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.0.16279.14433\Resources” into the ProgramData folder.

Do you have a “C:\ProgramData\McNeel\Flamingo nXt\Resources” folder on your computer? If so what is in it?

If the “C:\ProgramData\McNeel\Flamingo nXt\Resources” exists can you close Rhino, rename or delete the folder then restart Rhino and make sure Flamingo is loaded. Once Rhino has started and Flamingo is loaded you should have a “C:\ProgramData\McNeel\Flamingo nXt\Resources\Bitmaps” folder containing 84 files. If not please let me know what happens.


(John Morse) #4

We figured out what the problem was and are in the process of releasing an update that will fix it. The update should be ready this afternoon or tomorrow morning at the latest.


(John Morse) #5

I published an update this afternoon, you should be able to get it by running the FlamingoCheckForUpdates command which is available in the “Flamingo nXt 5.0/Help/Check for updates” menu.


#6

Hi,

Thanks for your help. Originally there was a Bitmap folder but it was empty. After deleting it it looked the same so I run the update and its working now. The folder has all those files now…


#7

Hi,

Thank you for the response…I have one more question. I am not sure if this is bug as well or its just me setting it up wrong but I have some issues with ground plane. I assigned ground plane with material from flamingo library (Asphalt- High Aggregate) and then removed bitmap mapping so that you can see this better. The only texture that the material has is bump pattern (sandpaper).

Notice how the texture doesn’t cover whole plane. Is there a way to set it so that it doesn’t produce this “cross effect”?

I am getting the same result even after new update.

Ticket mashine.3dm (5.8 MB)


(Brian James) #8

The ground plane is a special animal in that it is intended to go on infinitely. When you have a texture in a material applied to it, the scale of the texture will often need to be tweaked depending on how close the camera is. In this case I’d use a scale of around 2 I think if I’m imagining the intent correctly.

Post any new questions in a new thread please so they don’t get potentially missed. Thanks!


#9

Hi guys,

I have also had an issue with my materials library. I have the 90 day evaluation for both Rhino 5 and Flamingo NXT, which was downloaded only a day or two ago, so everything is essentially ‘updated.’

However, when I attempted to assign some materials to some objects, only the colors rendered, but not the textures or any characteristics of the material. I noticed that the materials were missing the link to the image that’s supposed to be associated with them and couldn’t find any folder that contained them.

Can someone please help? Thanks!


(Brian James) #10

Hi Mike, sorry for the delay, I believe this library issue is fixed with the latest auto update but the new build is not on the download page yet. Can you try the command FlamingoCheckForUpdates and then click Check Now in the dialog that pops up? Any luck?

@scottd or @JohnM can you update the nxt 5 installer download to push the fix for this out.
https://mcneel.myjetbrains.com/youtrack/issue/FL-6186


#11

Hi Brian,

I tried that command but it says it’s already up-to-date.


(Brian James) #12

Did you also click on Check Now in that dialog?


#13

Yep. It says “Your installation is the newest available.”