File Import Options not Saving

saving
bug
unhandled
options

#1

I’m having trouble saving a setting in the Options menu.
Specific issue is with the setting of Options>Files>Imported File Layers.

Default is “Use complete layer tree from source file”
Alternative is “Use existing layer tree from source file”

Change doesn’t stick after "ok’ (reopen options and it’s the same as before)
Also doesn’t stick when switching tabs without closing out of options. In fact, it glitches, showing both as selected (see attached image)

I just upgraded to 6.5 (from 6.4), but had not tried this before, so I’m not sure if the issue was present in earlier builds, or a new change.

System Info:
Rhino 6 SR5 2018-5-8 (Rhino 6, 6.5.18128.14431, Git hash:master @ c9d527277610c285bc57477182b5b0189a20a317)
Licence type: Commercial, build 2018-05-08

Windows 7 SP1 (Physical RAM: 16Gb)

Quadro K1100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 369.49)

Thanks!


(Pascal Golay) #2

Hello - I guess this is likely a Settings file glitch - see if forcing this setting:

Options > Advanced > Rhino.Options.FileSettings.ImportFileLayerMatchingOption to 1 makes things work as expected…?

It appears to be somewhat broken even from this setting - please set it to 1 and close Options immediately, then reopen and look in Files and see if that has been properly set.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45991

-Pascal


#3

Thanks, Pascal. That did it!

I hadn’t really registered that list before. Nice to see the settings all in one place.

Thank you.

Jo Kamm


#4

This was reported by someone else 2 days ago, I also created a youtrack item at the time, looks like the duplicate was recognized and already fixed for the next SR.

–Mitch