File Freezes + Graphics Issues : Shaded while in Wireframe

I am having an issue with a file regularly freezing, it seems partly tied to graphics issues and usually hangs in a perspective view in either a modified arctic view or shaded. The obvious sign that something is not right is that at times the wireframe view shows several objects as shaded, see below. It says it is wireframe, but half of the objects are shaded. Admittedly this particular issue is rare, most of the time it just maxes out my RAM and freezes, but this is the best lead I have towards finding the culprit. The file is about 105mb, I’ve got 16gb of RAM, 4-core 8ghz drive, GTX 1070 GPU.
When this happens it doesn’t use more than 20-30% of either CPU or GPU, but uses about 96% of the RAM. At this point I’m not sure if its a corrupted file, software compatibility issue, or hardware problems. So that narrows it down…

Things I have tried:
Rescue3dmfile: no errors
Audit: some block table errors but otherwise no problem
Export the model to a new file: I’ve exported everything out and re-brought in my levels, detail views, etc. Still having the issues.
Device Manager: Checked the Drives and GPU, everything seems to be working properly.
Hard Drive Space: I made sure there is plenty of space.
Dusted the inside of the machine: I figured a little cleanliness couldn’t hurt.

Plugins: Actively using Visualarq, Twinmotion is installed but not actively being used. Vray was installed a week or so ago but I uninstalled it for the time being.

Any insight would be appreciated.
Thank you!

Hello - Please run the SystemInfo command in Rhino and copy/paste the results here.


Here you go:

Rhino 7 SR3 2021-2-22 (Rhino 7, 7.3.21053.23031, Git hash:master @ f8a40388712d9cf7edc68910e0415427bdefc64a)
License type: Commercial, build 2021-02-22
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\ProgramData\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Your “SystemInfo” looks fine to me.

For troubleshooting this, I’d start by temporarly disabling all of your 3rd -parry plugins.

  1. In Rhino Options > Plug-ins, check the list filter at the top to Plugins that do not shipw with Rhino.
  2. Disable all of them
  3. Close and Restart Rhino

See if you can repeat the problem.
Assuming you can not, enable one of the plugins, restart, and try again.
Continue with this, one plug-in at a time until you find the culprit.
Then disable that one, enable all the others, and make sure the problem is gone.
Then enable that one again and see if the problem comes back.

My guess is you will have identified the specific problem plug-in.

What did you discover?

Thanks for the direction, I turned off all the plugins and switched it to a variety of view styles. I was able to spin around pretty smoothly in wireframe and shaded. Once I got to an arctic view with edges and spun around the model, it froze with two views overlapping each other like one of those cheesy Olan Mills photos.

Would this indicate its probably hardware?

Arctic is very OpenGL intensive.
With 2 standard resolution screens and 8GB VRAM you’re at the minimum recommended so should be okay.

If it were me, I’d try these two things:
Start your computer with only the single primary monitor connected.
See if the problem goes away. If it does, then it’s likely short of graphics power.
If it has the same problem, I’d update your GPU drivers.
Here’s a link to updated Nvidia drivers from late February, 5 months newer than you’re running now:

See if that works better with both 1 and 2 monitors.
Any luck?


Thanks so much for the help. The issue was the same between the two screens vs one, however updating the drivers did seem to help. Though it still seems to be hanging, specifically when converting from a shaded or arctic view to wireframe, I haven’t been able to make it totally freeze in the first 5 min like I could before. Now it mostly freezes for 10-30 seconds at a time and then resolves. I’ve also only been able to replicate it on one file, so maybe that file is extra heavy and my ram and/or vram (both of which are from 2016) are on their way out. Might just be time for an upgrade. I’m out of other ideas. It’s just interesting that it seemed to start out of almost nowhere rather than a more slow progression.

Thanks again for your help.

Since it’s just the one file, have you run SelBadObjects in it?
You might have an object with a bugered render mesh gumming up the works.

Another approach would be to start a new file with the same setup, then copy/paste mabe bylayer fromthe goofy file to the new one and see if you can isolate the offending objects.
Just a thought.


There don’t appear to be any bad objects in the file. I then split the more or less 100mb file into two separate files: 60mb of geometry with visualarq walls, slabs etc and 40mb of block assets like furniture and fixtures, many of which come from meshes. The block asset file is definitely in worse shape than the geometry file, but I was not able to isolate the problem to a single item.
I’ve ordered more RAM to triple my current speed. We will see if that helps.