Rhino crashing. Invisible curves?

I honestly have no idea what’s going on. Starting a couple of days ago, my Rhino (free trial version) has been crashing every single time I load up a pre-existing file. Not only crashing but also freezing my whole computer and forcing me to hard reset.

I can only open up a completely new drawing, and very unusually, all curves and wires are invisible in shaded view even though they’re supposed to be on (pic 1). They DO show in rendered and arctic view (pic 2), but they dissappear if you zoom out a bit (pic 3).
Really strange. any input on what may be going on? I already updated all my gpu drivers and my .NET Framefork

(NOTE: after testing, curves show (in close distances) in rendered, arctic, pen, technical, artistic display modes . They do NOT show in wireframe (where you straight up cannot see anything), shaded, ghosted, xray and raytraced)

how does your scene look in Wireframe ?

are you really using

Shaded ViewPort
Wireframe ViewPort
the middle of those 3 buttons / icons ?

Screenshot 2022-11-27 at 01.53.05

Might be, that you use Shade (left button) and curves are set to not show ?

Are you using the latest driver for your graphic card ?
are you on a laptop with multiple graphic cards ?

check preferences:
→ View → OpenGL → Video Hardware
what is written there ?

are you running any plug-ins ?
run rhino in Save Mode ( this will run rhino without any plug-ins)
(just type in the windows search field Rhino Save Mode…)

if above does not help, there is a command
post the content here, so one of the mc neel brains can have a look at it.

good luck - kind regards -tom

Hello Tom.

My scene in wireframe looks completely blank. Only the grid visible.

Yes, I am using that same viewport. Curves are set to “show”

I have the latest drivers and it’s my only graphics card
Below is a screenshot of my video hardware screen in rhino.

Oh wow. I did just test save mode and the wireframe DOES display properly! So I guess it’s a plugin issue. Which is weird because this is a clean installation of Rhino from a couple of days ago. Thank you so much! now I guess i have to disable the in-built rhino plugins? I’ll try that and report back how it goes. (EDIT: it did not work. Problem persists)

Anyway. Here’s my systeminfo too just in case it’s useful:
Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Evaluación, build 2022-11-04
License details: Cloud Zoo
Expires on: 2023-02-19

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 12Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX550/550 Series (AMD) Memory: 2GB, Driver date: 11-10-2022 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-10-2022
Driver Version: 31.0.12029.7019
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 7917 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

video hardware

We’ve seen the this type of errors since the latest driver update for AMD GPUs was released. You have two options:

  1. bump down the OpenGL level in the OpenGL settings in Rhino Options
  2. downgrade AMD GPU driver
1 Like

Thank you Nathan! I lowered my OpenGL and the problem was fixed.

Thanks all for helping

1 Like