ExtrudeSubD does not support DragMode View

Hi
I work in DragMode View, but the ExtrudeSubD and ExtrudeMesh commands at the first onset switches to normal mode and I can’t control it. The resulting extrudies move uncontrollably in the scene.
This is a strange behavior, probably a bug.

In addition, I would like to ask you to add an option for normals with a given distance. This should work like Offset.
_
Offset request.
Now _Ooffset is applicable to the whole Subd model, I would like to choose the face and apply offset selectively.
Can add this?

Thanks

You can use the gumball

Thanks Martin, but I forgot to say in my first post
I couldn’t get used it, I don’t like Gumball. Therefore I do not use it

That’s funny.

The use of the face normal with ExtrudeSubD is filed as https://mcneel.myjetbrains.com/youtrack/issue/RH-49859 , I added your vote. Thanks!

1 Like

Thank you Brian!

The command is not functional, the gumball is not activated either. Choosing the “free” option it is very difficult to manage the extrusion, especially in the perspective view, in fact it almost always creates a defect in modeling.
Can be assimilated to the tspline command “tsextrude” (allow me the analogy).

Activating the gumball is a must in this command!