Exporting to PDF Looses all Line Weights

Hello, I have tried printing with multiple PDF creators and none of these work.
Bullzip PDF

I have tried printing from view port and form layout. No matter what lines weight are always the same.
I also opened each pdf in Ai, they all have 0.042mm lines.

I have carefully set lines weight for each layer, checked the objects where in the correct layer. Even turned on PrintDisply, and I can see the line weight difference in both viewports and layout.

No idea what Im doing wrong.
Thanks in advance.

Rhino File Beams.3dm (308.8 KB)

PDF File PDF no line weight .pdf (48.2 KB)

This seems strange, I have no trouble with lineweights out of Rhino 5 on windows. Your file download link isn’t working, so I can’t check your file - maybe try re-uploading the rhino file? I can consistently export to .ai with lineweights preserved, though it does a conversion from mm (in rhino) to pts (in illustrator). When I print to Adobe PDF my lineweights show up just fine.

lineweights.pdf (5.6 KB)
lineweights.3dm (160.2 KB)

Re uploaded file, its working now

The file is in layout, make sure you got print display on to see the line weights.

They dont in mine…

Hi ShynnSup - in the Print dialog, scroll down to the “Linetypes and Line Width” section and scale the line width up some - I don’t know how much you’ll need.


Hey Pascal, that helps, but how do I make it so that they match size I choose for them before printing. The scale would be 1:1, but that results in not the correct scale again… As they all look the same when they are not…

Any ideas?

I’m having the same problem. Did you find a solution?

I honestly don’t remember what solved it. I think I restarted the pc and then it worked as normal.

Anyways, this was with Rhino 5, so no longer an issue.

Thanks for responding.

I’m using Rhino 6. I lose line weight and transparency when I print to vector PDF. It looks correct in raster but I cant use raster in this instance. I can’t find a solution.


Are you using Rhino’s 6 pdfer? If so, are you printing to a normal sized page?

I suggest you to start a new thread and upload your file there, or at least here.

Michael, I am having the same problem as you- I can print to raster and have lineweights just fine, but vector loses all line weights, did you ever find a solution?



Hi @A_Mac - It seems to be working here. Have you tried with Rhino 6 and RhinoPDF?

Hi @Vanessa turns out my pdf viewer was set to not display line weights by default…

It’s working now, what a relief! Thanks for your advice.

4 posts were split to a new topic: Printing to pdf pixelated

Hi Pascal,

Thank you. Attached is a screen shot of my layout page/ line weights and the pdf it creates.


vector test 1.pdf (121.3 KB)