Print Vector PDF lineweights

Dear Rhino community,
i have a big problem when i print vector PDFs in Rhino 6.
When i choose in the print setup vector output, all lineweights are the same.
When i choose raster output all lineweights will print in the correct width.

Moreover using the Rhino 6 file in Rhino 5 all lineweights print correctly.

Is this a bug in Rhino 6 or a problem of my system?


Is there nobody with the same problem? :disappointed_relieved:

Hello - can you please expand the setting in V5 for line types and line width a take a new screen shot of that?



Hello Pascal,
l upload a picture of the line widths and linetyps settings of rhino 5 and 6. Also I updated all drivers of my computer and used different pdf-printers like bullzip, cute pdf, adobe pdf, rhino pdf etc. In Rhino 6 I get all the time the same line width problem. :pensive:

My system is a alienware 17 a4 including a nvidia 1080gtx graphic card and with a 4K monitor.

Until now I am very happy with Rhino 6 except of this vector printing problem…

And here are the Rhino files with the lines.

Rhino_5_1.3dm (120.7 KB)
Rhino_6_1.3dm (124.7 KB)

Hello - thanks - can you please also run the _SystemInfo command in Rhino and post the results?


Output of the systeminfo command:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Studentenlizenz, build 2019-02-27
License details: Cloud Zoo. In use by: maximilian.hertwig ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-26O1DAO

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1080 (NVidia) Memory: 8GB, Driver date: 5-7-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 397.64

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-17-2017 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-7-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.13.19058.371
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2018.10.30.683\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp “SectionTools”

Hi Maximilian - can you please try opening Options > PlugIns page and disable the various non-default plug-in (VisualArq, Vray, Lumion) then restart Rhino and see if that has any effect? You might also look for a driver update notification in the Notifications panel, double-click and go through the process of updating (both NVidia and Intel) drivers. Let us know if either of those does anything.


Hey Pascal, i did everthing you write but nothing changed. :sweat_smile:
Updating Nvidia, Intel drivers and disable the different plugins don’t slove the problem…
I also made a Make2D and try the diffrent rhino viewport display… same story…

I do not know how to continue… :sweat_smile:

Do you get the same results if you try “Rhino PDF” as the destination in V6?

Yes I get the same result with the RhinoPDF printer. it’s crazy… I hope we will find a solution.

push… :v::grinning:

I have found an old thread from August 2016. Somebody has the same problem like me:

An idea was to scale the line width up in the print setup ( Linetypes and Line Width). But there is a problem because the lineweight I scaled manually is not right to the scale i set in the printer setup.

Hi @maximilian.hertwig,

Can you reproduce the problem if you create a new file in Rhino 6? Or does it only happen when opening a Rhino 5 file?

I tried reproducing this by opening your file in Rhino 6, no luck. I also tried on a high-DPI display - no luck.

Hey David,

here are the answers to your questions:

Can you reproduce the problem if you create a new file in Rhino 6?

When I create a new Rhino 6 file there is still the same problem with the lineweights in vector print. I only get proper lineweights when I safe my Rhino 6 file as Rhino 5 and print in Rhino 5.

Or does it only happen when opening a Rhino 5 file?

No, I create and work on my projects in Rhino 6 and also safe them as Rhino 6 files. Only for printing I go the detour with Rhino 5 to get proper lineweigts.

I tried reproducing this by opening your file in Rhino 6, no luck. I also tried on a high-DPI display - no luck.

When you get the same results like me… is it possible that this is a bug in Rhino 6 which every Rhino 6 user have?

Greetings from Germany


I’m still having trouble repeating this bug. Could you please update to the Rhino 6 SR14 release candidate?

The bug may have been fixed in the last two months that we have been working on SR14 and I want to make sure we are looking at the same thing.

I have the same problem. The layer print width doesn´t do anything but I work around it by going through properties panel with every individual curve and there set their print width and it works with the printer too.

Please run the SystemInfo command in Rhino and post the results here