Lineweights not printed in Build 5A745

Lineweights are not printed in Build 5A745 - vector output.

I’m able to get them to print in 5A745. Did you run the PrintDisplay command to get weight and linetypes to show up?

problem still occurs in Release Candidate 4. Print dialog - vector output - save pdf. All lines are printed in same weight.

Can you post a sample 3dm file as well as the resulting PDF and a screenshot of the Print dialog settings you used? I’ll take a look and see if I can tell what’s going on.

PDF.pdf (18.2 KB)
example.3dm (580.8 KB)

Thanks for sending the 3DM and PDF.
I used Build number = 5A855.
There is definitely a difference between the raster and vector.
Right now, I am not sure which is right.

It sounds like you feel the raster plot is correct.
Is this true?
See PDF output attached.
Thanks for your help.

Mary Fugier

cc @dan
raster_plot.pdf (178.3 KB) vector_smaller.pdf (10.9 KB)

using lastes 5.01 build:

  • VECTOR OUTPUT - all lines are printed in 1pt weight (opened in illustrator) - paper size A1
  • RASTER OUTPUT takes ages for A1 page size, but results are accurate - as in your raster_plot.pdf

I’m sorry. I’m still lost :frowning: Perhaps I’m too focused on the initial report - which I read as: “Lineweights are not printed in vector output.” I am unable to repeat this. Lineweights are printing for me in vector output mode. Now, as @mary says…

Yes, they are different…but that would be different issue. @epiphany is “being different” your concern? I don’t read that in your post:

It seems we are seeing different results. Sorry, I’m probably missing some critical nuance, so please be patient with me.

please see this video:

I think it should be related to following issue:

  1. quit completely
  2. open rhino, create new model. Draw eg three horizontal lines lenght 100000
  3. assign each line to different layer, set different layer Print Width
  4. Enable PrintDisplay - Color Display, Thickness 80
  5. close drawing without saving changes. DO NOT QUIT
  6. Create new model, repeat steps 3, 4 HUH, PrintDisplay is automaticaly enabled and cannot be disabled or changed until is restarted

Thanks. I’ll follow these steps. In the meantime, what are the contents of your Linetypes and Line width settings?

Ok, when I do the first three steps (1,2,3) I get what I expect…I get lineweights in vector output. Not sure why you are doing step 4…but I’ll follow you down that path if you want.

I cannot repeat this. PrintDisplay is not automatically enabled for me.

see this video

  • create new model
  • draw two lines
  • set one width to 0.35, other remain in default width (0.13 in print dialog)
  • print dialog with settings displayed above
  • PDF - Save as - both lines are printed with 0.352mm width

Odd. I’m still not getting that behavior. There must be something we’re both doing differently. I followed your steps above and here is the model I used and the PDF result…as expected, different line widths…

LineweightTest4.3dm (38.7 KB) LineweightTest4.pdf (4.2 KB)

I’m stretching here, but could you do me a favor and set your OS X locale to en-US? Something about those commas (see the Point objects: 0,5) are bothering me. Do you see different results when OS X thinks you prefer US-centric locales? Perhaps we are not being culturally sensitive here somewhere. I will test this myself, but nothing beats testing on the machine that is giving the trouble.

Additionally, I noticed that your printer is set to AdobePDF. What happens when you set that to a different printer and still use the OS X-based PDF button in the lower-left-hand corner? Any different?

Hi Epiphany,
I updated to Build number = 5A858.
It appears the print weights now look very similar (nearly identical) between Raster and Vector.
Vector looks sharper and corners are mitered.
Raster looks ok, and thicknesses are comparable.

In addition, I see the following print weights:

  • I get a print weight of hairline for lines on the green layer.
  • I get weight of .default print weight for the red lines which is set to .25 in the Print dialog.
  • I get a print weight of .30 for line on the blue lines.

Please reference attached images.
In addition to address Dan’s questions from the previous reply, we would like to know if you have the latest build and how it is working for you.
Thanks for your help.
Mary Fugier

thanks for tips:
latest build

  • locale change/app restart - same result
  • 5A858 - same problem

seems to be related to printer driver/page size? With AdobePDF or CUPS pdf driver ( on A1 paper size are lines printed weight.
With A3 office Epson printer all lines are displayed correctly, but actually there is no way to print larger drawings than A3 :confused:

Hi Epiphany,

Do lineweights in the Raster more work for as you would like?

What is the Default Print Weight set to? .13?
Also in the video where you show setting the orange layer to .352mm in the Layer panel.

Also, I would like to see this model. Would you email me this model or a small part of it?
How is PrintDisplay related to all this? Print display will not preview the default line weight set in the Print command.
Please look at the attached plots, variety of scales, line weights and sheet sizes. I tried to break it but the results are as I expected.

Dan and I both feel that we not understand exactly what the problem is yet. Sorry about that.
Also are there any other Rhino for Mac users who are getting the same problem? If yes- please chime in.

Thanks again,
Mary Fugier

A1_vector.pdf (19.3 KB) 36x24TestPlotVectorDefault5.pdf (19.2 KB)

36x24TestPlotRasterDefault5.pdf (1.6 MB) A1_raster.pdf (1.4 MB)