Exporting a .3DS file grouped by layer


#1

Hey guys, newbie here. I’m exporting a wheel design as a .3ds and importing it into Blender to render. However, it imports and splits it into individual layers (hundreds) in Blender for each surface, as opposed to importing it split into the original layers from the Rhino file. This, of course makes it ridiculously tedious to manage layers in the Blender file. Is there an export setting in Rhino that assures it is exported by layers ? I’ve imported a .3ds file I exported from ACAD into blender and it maintained the original layers, so I’m guessing it is a Rhino tweak and not a Blender issue. I appreciate any help anyone can provide !


#2

Hi Kirk, is there are specific reason for using the 3ds format ?

You might get better exports from Rhino to Blender using obj format. It supports transport of layer names object names, Materials as well. Below are some settings to export to Blender as obj using the layer names in Rhino. In Blender you´ll get one object for every layer in the outliner. For larger scenes, i name my objects / groups in Rhino individually and use the setting to export Rhino object names as OBJ groups. This way you´ll end with one named object in the outliner for every named object in Rhino.

You´ll probably mean not blenders layers but objects in the outliner, as Blender supports 20 Layers max. But using obj and the settings above it`s possible to spread your imported objects onto these layers using the outliner.

does that help ?

c.


#3

Hi Clement,

Well, the only reason I was using the .3ds format was because I used it previously exporting from ACAD and it was successful, so I defaulted to that. However, I tried your suggestion using the .obj format, and it exported fine, but I got an error when importing into Blender. I went back and checked the export settings in Rhino and noticed I had “Wrap long lines” checked, and apparently Blender doesn’t like this option, because when I tried exporting again with it unchecked…success, and it created one object per layer ! And yes, sorry, I meant objects the Outliner, as opposed to layers.

Anyway, thanks for the tip, much appreciated !