Export OBJ failure

I’m just trying to export a model to OBJ format and get the following message after all the meshing has finished -


Is there any user error that could cause this? Never seen this before, but haven’t used obj format for a while.

Many thanks in advance!

Hi Rob - is that path that’s smudged out to a folder that is synced to the cloud by any chance, Google Drive, Drop Box etc?

Does it work to just export a box or something simple?



No cloud here, just saving to a local folder on the C:\ drive. I’ve already exported an FBX to the same folder - which worked, but I didn’t like how the FBX didn’t keep my layers when imported into Blender, so wanted to try the trusty old OBJ.

Tried to export one single surface but get the same error.

It was modelled in another bit of software but I can’t imagine that would affect an export?

I also downloaded the latest Rhino6 build but got the same error.

I could send the model if needed, so long as you keep it under your hat!



I would ensure there aren’t any invalid characters in layer, object and material names. IIRC there have been fixes to this area in the past few Service Releases, so maybe you want to ensure you are actually on the most recent possible.

If you don’t mind using Blender 2.80, you could also use my import_3dm Rhino file importer - it’ll retain the entire layer structure you have as a useful collection layout in Blender 2.80.

Thanks Nathan, will give the naming a try.

As it happens 2.80 is what I’ve downloaded! Would love to give your importer a try as it’d save all this fbx/obj hassle. How can I get my hands on it?



I hope the instructions are clear enough.

1 Like

Well…first impressions - I’m impressed! Nice work Nathan. I need to check through the model and make sure everything has come through ok, but initial indications are good.

One thing for other people trying this to note is - convert your Rhino model to metres first.

Hello, I manage to install the add-on and I check on the addon folder and it is effectively there, but the import .3dm option does not show on “file - import”. I have blender 2.81, not sure if that is the issue… Could you help me please?