Error SetDotNetRuntime

Hello I have an issue.

I tried to install the Shapediver plugin for Rhino8, it asked me to switch my .NET Runtime to Framework :
image
I changed it, restarted Rhino, and it gave me an other error :


How can I fix this ?

Thank you for your help !

Have you tried updating to the newest shape diver?

Do you mean installing the latest version of ShapeDiver ? I have tried with the version 1.17.1

This issue is due to conflicts between .NET Core and .NET Runtime. Since the latest service release of Rhino allows to publish multi-targeted yak packages, we will release a new version of the ShapeDiver plugin early next week which should fix this issue. I will update this topic once it is released.

2 Likes

We released version 1.17.2, which supports both .NET Framework and .NET Core. You can switch using SetDotnetRuntime in Rhino 8, and both should work.

Hello and thank you for your help !

I’ve tried installing the new version of ShapeDiver you mentionned but I ran into another issue.


I’ve tried switching to the .NET FrameWork but I stil run into the same issue as before

Then, I noticed that my first issue was similar to this issue : Error loading shapediver plugin in grasshoper windows. I found a file AutoMapper.dll in an other plugin I had installed, so I uninstalled this plugin, and the installation went smoothly.
But now I have trouble reinstalling this plugin, I’m in contact with their support as I believe this issue is on their side and not yours. But I would like to know if it’s possible to have both plugin installed on the same machine ? How should I proceed if I manage to reinstall this plugin ?

@snabela
I have finally managed to reinstall everything but I still have the same issue : Is it possible to have both plugin installed at the same time ?

There seems to be a conflict of dependencies between the ShapeDiver plugin and this other one. Could you let me know which plugin that is so I can test on my machine?

If you switch to .NET Framework, the error you get seems to only concern the ShapeDiver Desktop Clients plugin, but it should not affect the other standard features of ShapeDiver. In case you don’t plan to use the desktop client features, did you try to ignore the error message and use the standard ShapeDiver components anyway?

@snabela please do the following: Right-click the Automapper.dll which comes with the other plugin, and let me know the version of it.

I’m using the Dlubal-RFEM plugin.


I don’t know if you need a RFEM license to download the plugin, but since it appears in the Rhino Package manager I assume you will not need one.

I’ve tried both version of the .NET Framework and I have an issue in both case, if I just press continue I can open Grasshopper but I don’t have access to the ShapeDiver component (The Squid plugin is installed though).

Here’s the error message if I try with the .NET framework :

And here’s the issue when I try with .NET Core :

Hope that helps you

Is this what you need ?

Due to compability issues, the ShapeDiver plugin is using an older version of this dll, which is why there is a conflict between the two plugins. Our plugin might stop using this dependency in the future, at which point it will be possible again. However, at the moment, it will not be possible to use these two plugins at the same time in a definition.

1 Like