Entire model disappeared after editing block

If you have not closed the file, please Undo and see what turns up.

-Pascal

I have tried undo and while it appears to undo actions, no objects appear

Can I send you my file or share my screen?

Yes - please UndoMultiple first, just in case that helps recover the model - also, before you save, locate and open the 3dmbak file of the same name in that file’s folder and save that to a new name - this may help recover your stuff as well.

SaveSmall, Zip and send to tech@mcneel.com. with a link back to this topic, please. If it is very large, upload to www.rhino3d.com/upload.

-Pascal

I’m afraid there is no 3dmbak file in that folder, how can I find this?

Hello - sorry - I just realized we’re on a mac here. If you go back in file versions, you should be able to revert to a previous version.

-Pascal

Okay sure, how do I go back in file versions?

Nevermind sorry I got it - that’s amazing, I didn’t realise that feature existed! Thank you!

RH-57400 is fixed in the latest WIP

Just had this same problem on Mac Version 10.14.6 Rhino v6 (6.30.20288.16412, 2020-10-14). Unfortunately I saved and quit, and am not seeing any previous versions.

I’m having the same problem. And when I went to try and restore past versions my Mac froze up. I’m currently waiting in horror at the possibility of losing all my work. Does anyone have any advice on what I can do?

This is still a problem and restoring to previous version didn’t work. Is there a solution to this and how do I create a separate back up file on Mac?

Hello - can you please run the SystemInfo command in Rhino and copy/paste the results here?

-Pascal

Same issue here. I edited a block and entire model deleted after.
I have tried undo multiple and does not work.

Running Rhino 7 on Mac

Hi -

Please run the Rhino SystemInfo command and copy-paste the result here.
Can you reliably reproduce that issue in a new file?
-wim

Hi,
I just had the same issue. Edited a block and then entire model went missing. The model is still 147MB so the objects should still be saved in the file.
I have a backup one hour ago but it still wasted me around 2 hours.
Let me know if you want my file to look into it.

System Info:
Rhino 7 SR8 2021-7-15 (Rhino 7, 7.8.21196.05001, Git hash:master @ 45c1fd6dc85c7c1cce8c0bbe6f3e16481ae9abfa)
License type: Commercial, build 2021-07-15
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P3200 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 3-11-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-30-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-11-2021
Driver Version: 27.21.14.6192
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\CWAI\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.20335.757

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.8.21196.5001
C:\Users\CWAI\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Any solution here? Same issue just happened on a late stage model with a ton of work.

Any solution yet???
I can’t lose this model!
In the audit, all of the objects, etc. are still in the file, I just can’t see anything beyond what was in the block I was working in. And I made the mistake of saving the file with a new name, hoping I’d get an autosave or something, so I can’t revert.

ctrl+z then before you exit the block editor, copy the block and lock everything else. exit the block editor, when your block disappears paste it back and select replace. Unlock the rest. Locked objects should not disappear.