Can't get out of block editing

unhandled

#1

Dear Rhinoceri,

For some reason, while editing a block, the Block interface disappeared. So I was not able to push the close/update button.

Not beeing able to exit the block-editing modus, all other geometry in my drawing stayed frozen. So I thought exiting Rhino alltogether and restarting would fix it… Unfortunately, when re-opening this drawing, it starts again in frozen/block editing modus.

Could someone shed a light on this behavior?
Thank you ever so much!

  • Bart

#2

Visibility > Unlock Objects

Excuse my newbie remark… This ‘behaviour’ is most probably just Rhino locking all geometry, just before going into Block Editing… After incorectly leaving Block Editing Modus, the locked geometry didn’t get back in it’s earlier state. Hence the ‘behavior’, just as if Rhino was still editing the blocks’ geometry…


(Pascal Golay) #3

Hi Bart- unlocking is a way out, but you should never need to do this - I’d like to know how the dialog disappeared in the first place- do you have any idea what you were doing when it closed?

thanks,
-Pascal


#4

Hi Pascal, thanks for taking intrest.

If I’m not mistaking, I was (re)arranging the different menu-windows, activating new tool-bars etc. while in Block-Edit Modus. I have a duo-screen setup. Running Rhino64bit on Windows7 with a Samsung USB Monitor SMD220SU as second screen.

I just found another glitch with Block-rendering. Also some hickup in generating the interface / toolbars for which I opened another issue here

–Bart


#5

This also happened to me when using grasshopper on objects in a block during block edit mode.

Using the unlock objects command has caused the block I was editing to explode.

Not a big deal for the model I am working on, but I imagine it could be if my block were more complex.


#6

Hellow to everyone, the same thing happened to me, does anyone had found the solution to exit the block editing without using unlock?? Since I have a lot of information as reference below the things I am redrawing and they are not grouped, so at the time I use unlock all the information would get mixed!

If anyone knows, let me know please!

Thank you all.

Sabrina


#7

This just happened to me in the Rhino for Mac WIP. I wasn’t even editing a block at the time. Might have double clicked into it accidentally but not likely as I was using the layer window to turn off layers in a block.

-Brandon


#8

Same issue here - This happens to me very frequently and it is annoying. I am pretty sure this has something to do with clicking the spacebar while trying to do other commands during the block editing. I noticed the edit panel goes away the moment I press the spacebar.

As for the note to use the “unlock command”. Once this has been implemented, every block created within my file is released from being a block.

I have also noticed that when working on a block item in a separate window, the command bar does not auto populate as you type. This can also being troubling for people who have difficulty spelling…(sad sigh).

TO ADD, I AM USING RHINO FOR MAC AND I JUST REALIZED THIS IS NOT THE RIGHT THREAD FOR THIS. MY APOLOGIES!!!

Best,
Shane


#9

I’ve had this happen several times. and just cam across this thread. I used unlock to get out of the blockeditor, but now the block is again individual objects–even though the block manager shows the block existing. Do I need to make them a block again? Is there a reverse to the “unlock”?


(Pascal Golay) #10

Hi CalypsoArt - what happens is the block instance is exploded in this situation - so is Undo does not get you back where you started, you can Insert another instance of the block.

-Pascal


#11

this happened to me recently - The block-edit dialogue box disappeared when using copy / paste command within the block editing fucntion - specifically when I pressed command V - it just disappeared. I had to use “unlock” to exit out.


#12

There needs to be a way to bring back the Block Edit dialogue box. I accidentally hit the X in the top corner and it closed without exiting the block. I’ve just had to unlock everything, even things on off layers to get back to a usable point, then put the block back in.

Note: When you save it when editing a block it saves it in the current state, but i would have lost work if i had just closed without saving.


(Pascal Golay) #13

Hello - here, in the latest at least, if I am in BlockEdit and I close the dialog from the ‘x’ , the block reverts to it’s previous (un-edited) state. So, I think, if I understand it, what you describe has been fixed.

-Pascal


#14

Hi Pascal, yes, just updated tot he latest RC and it does look like it’s fixed, thanks. :smiley:


(Djhg) #15

My experience has been that if I save a project from block edit mode, it will open in that mode but without the block edit box.


(Shadowrider921009) #16

Yes I noticed this too, on the latest Rhino v6, spent ages trying to figure out how to get out, ended up using unlock to get out.


#17

Ok, it happened again, this time by pasting a point into a block, it greyed out the block edit box buttons so the only thing i could select was the X. It locks everything on Off layers as well so it’s not just a case of using the Unlock command, this needs to be done with all layers turned on.

I saved my layer state, then turned all layers on and unlocked everything. Then reloaded the layer state, this would have worked well if the block wasn’t now exploded. So I now either re-insert and re-position the block or close the file, lose the work and start the changes again.

EDIT: I’ve been able to copy the block from the previous saved file (I hadn’t saved the file during this issue) so i have the block back in its place and everything is now back to normal. So this is a work around the problem.

Can there be added a manual ‘Exit Block Edit’ command?