DWG importation problem


#1

Hi,

I just updated my licence to: Rhinoceros 5.0 Wenatchee 2013-08-21 (474) version.

It seems that Rhino is no more able to import DWG files. After choosing the file to import a document window opens, but the spinner is turning undefinitly.

Thanks to correct that bug

Kind Regards


Importing obj inot the latest version of mac rhino
(Pascal Golay) #2

Hi Adevita- I just tested this here with a simple dwg file and it opened as expected- is your file very large? Can you test with a simple file just to see if the mechanism is working? I’ll attach one here- just a box.

-Pascal

Test.dwg(13.5 KB)


#3

I’m having the same problem here only it effects imports of multiple filetypes. I’ve had problems with .ai files and dwg files. All of the files I’ve tried to open are under 1MB. I tried to open the simple dwg that you posted and I just get the grey screen with the spinner.

I just updated to: Rhinoceros 5.0 Wenatchee 2013-08-21 (474) today and the problem started rught after that. I’ve never had this error with any of the other builds.


(John Brock) #4

I’m getting the same endless spinning twizzle on my MBP.
The DWG file opens just fine in V5 for Windows, and in AutoCAD 2013


#5

I can neither Import nor Open the file you posted @pascal… just hangs with the spinning wheel. Freshly downloaded build 475 (today’s date)…

Also funny, if I choose Import, it creates a new untitled Rhino window - shouldn’t it import into the active file window?

–Mitch


(John Brock) #6

A few more details…
I opened the file Pascal attached in AutoCAD 2013 and saved it again.
Wentachee 474 can’t open it.
I drew some curves in Wenatchee and saved it as DWG. Wenatchee can’t open that either.
It’s something for @Marlin to have a look at.


#7

Pascal,

I have tried to open your file, and it is not working either. It also seems that I am not the only one in that situation.

Alain


#8

I have the same problem with dxf files. An example file is here: https://www.dropbox.com/s/9m91zuum9dsga6e/sup_frl_v21.dxf
My last version expired in july or so and that one could open this file fx.

Let me know if you need more info about my system or so.
Thanks.

Ola H.


(Marlin Prowell) #9

I see this problem, and it happens with all non-3DM file imports. There will be a new WIP release soon to fix this.


#10

it’s always done that… i thought it was just rhino as a whole which had this weird (to me) behavior… didn’t realize it was mac specific


#11

Nope… definitely not supposed to be that way… Open should open a new window - at least on Mac I guess - in Windows if you want to have a new window you have to open another instance of Rhino; but Import should import the file into the currently active instance. That’s what it’s for - otherwise you wouldn’t need an Import command… :confused:

–Mitch


(Marlin Prowell) #12

This is fixed in the 2013-08-23 WIP release.


#13

Good to know you guys are on top of this one. I just ran into it today with some files i was exporting. I always open them after an export to make sure all the data is there, but i wasn’t able to QC my files today. :frowning:


#14

When I import a DWG file into version 5.0 Wenatchee 3.5.14 it opens a new window rather than uploading it into the existing file. Anyone else having this problem?


#15

Yes, actually this seems to have been the case for a long time, if not since the beginning, if you look in the menu, the shortcut key for Import is the same as the one for Open… Why is this necessary? Is this a Mac limitation? If so, it’s a pretty severe one… Although you can use Insert to insert a file as objects, with that, there is always the danger of accidental scaling or wrong insert point…

–Mitch