Rhino 6 import function not working

I downloaded the new update today and exported this DWG (attached). I cannot import it back into Rhino 6 - but I can when I try my old Rhino 5. I also quickly tried sketchup 2013, DXF, 3DS and had the same problem. Thanks for looking into it!

079.03 190530 Tube Drawing Test.dwg (56.2 KB)

I can not duplicate that.
I was able to Open your DWG file in both V6 for Windows and V6 for Mac.
Do you get any sort of an error when you try to open it?
079.03 190530 Tube Drawing Test.3dm (4.0 MB)

I’m confused by the second part of your message.
Do you have SKP, DXF, and 3DS files you can’t open in V6 as well?
If you don’t supply them, I can’t test for an error.

Thanks for chasing this down. The forum won’t let me upload a 3DS file but here are the SKP and DXF.

I don’t get an error - it just doesn’t get past thinking after I accept the defaults for opening it (I left it over a coffee break, bathroom break, etc) but in V5 it opens immediately.079.03 190530 Tube Drawing Test.dxf (296.2 KB)
079.03 190530 Tube Drawing Test.skp (374.5 KB)

Both of those opened for me too.
They took a little longer (a few seconds) than Windows V6 does but they still opened.

I’ll ask @dan and @marlin about this to see if they have any ideas.

Are any other V6 Mac users able to open these DWG/DXF/SKP files?

Please open About Rhinoceros and take a screenshot.
I want to make sure we’re both running the same software.

Please see attached

Okay, that’s a difference.
I’m running the latest WIP and you’re running the Beta which has different “branding”.
There may be a screw up in some of the plug-ins.
I’ll see if I can install the Beta without breaking everything else.

I’m seeing the problem with the Beta build.
I’ll get this in front of the Developers.

1 Like



This should be fixed in the latest RhinoBETA for Rhino 6 for Mac. Please give it a try. Thanks again for reporting this.

Works now, thanks!

1 Like