.dwg, .dxf exports failing - then total file collapse

Hi there.
I’ve exported many a .dxf and .dwg for CAM using the exact same process- and suddenly, today,
I started getting a pop up that says “an error occurred and the file XXXXXX cannot be saved”
whenever I tried to export either file type.

I closed the file thinking a close/ reopen might straighten things out.
When I reopen the file, it’s completely empty- zero kb- not even the default layers are present.
I tried to revert/restore, and I can see the file complete as I left it last- but when I click ‘restore’ all that opens is a blank file. Halp! I’m on a deadline with the CAM vendor standing by waiting for their dwg- it’s terrible timing!

I have a 1tb HD with 34 GB free space
Rhino 7 on MacOS Mojave 10.14.6, i9

My export process is to rotate my export content to the Top View (in this case a few simple 2D curves, text and one Leader)
Select and ‘export selected’
I use Dxf/ Dwg “r12 Lines and arcs”

Hi Laura - is the export to a standard local folder or in a ‘synced’ folder like a Google Drive?


Hi Pascal- I’m using standard local storage.
While I was able to restore the file I was working on Saturday from my time machine backup, I have since realized that all the files I worked on yesterday and this morning, when I tried to open them, get converted to no layers, no geometry, zero bytes. I can ‘rescue3dm’ and see the visual preview of how the file should look, but it won’t actually restore the file. I’ve lost a long Sunday of work as well as the weeks before, in one large and detailed file especially. I tried calling rhino tech support and am following advice to back everything up and switch machines - I have an old laptop limping along that I can use-
but I’m wondering if there is any way to access autosaved versions from within Rhino, that aren’t part of my time machine (which stopped backing up Saturday night, for some awful nightmare confluence of circumstances)

Any help you can offer is much appreciated. I’m in a mess of deadlines on the three now vaporized projects, of course.

Hi Laura - just to get the symtoms right - what files show 0 k size - just the ones you have exported (with failure) from?


This has happened to all 3 files that I tried to open today. Whatever is going on is bigger than the export issue- I was able to get that done since a copy of the file with the export option was recorded in my last time machine backup (saturday night). The next two files I tried to open said something like ‘this is not a Rhino file’ and then opened empty, no layers or geometry. When I look at the file sizes, they read 0 now. When I try to ‘rescue3dm’ the same thing happens- an empty file opens. Unfortunately one of those files especially represents weeks of work, and a ton of hours put in yesterday refining details that I’m not sure how to recreate. Is there any avenue for restoring from Rhino’s autosave feature? Or other ideas? I’m copying everything over so I can try from my other machine, but I’m worried about losing the autosave database when I take this machine in to the Genius Bar this afternoon. I’m really hoping there’s a path to recovering those files first.

I didn’t try to export anything from the second two files- I just opened them to keep modelling after restating my computer.

@dan - do you have any idea what might be happening here?


No, unfortunately, I do not.

@laura2 I presume here you are referring to the macOS Versions Autosaved files. Have you tried looking at the contents of the previous saves in the last-known-good file? You would view these from:

File > Revert To > Browse All Versions… If there are Autosaved versions of your model, the Version browser will appear.

My presumption here is that you would only see versions from Saturday, which I doubt helps in this circumstance.

When you run your exports, are you overwriting previously saved files with the same name in the same location? (Apologies if you’ve already stated this above).

When I export dxfs or dwgs-s it’s always a sub-part for machining, etc. Those export files always get re-named with the part, vendor, project, date etc. (not overwriting the Rhino file with the same export file name)

This complete vanishing happened with a total of 3 files: only one that I tried to export dwgs from.
I opened them after restarting my computer, there would be no layers at all, and no parts in the file. From that point on, looking at Finder showed a file size of ‘0kb’ (but all 3 had normal file sizes before opening)

Thank you for confirming that.

What do you see when you navigate to System Preferences > Apple ID > iCloud Drive (Options… button) > Desktop & Documents Folders ?

Is Desktop & Documents Folders checked?