Drawing and layouts disappear when closing block edit

I accidentally saved a drawing with block editor open,Now when i open the drawing i cannot close the blockeditor without my complete drawing disappearing,I am assuming it’s something to do with the display rather than the geometry,as the blocks are still there

Latest V6 version


Sorted it out by saving without plug in data…

Hello - try opening the drawing and run Unlock. Does that help anything?


1 Like

I tried that,I just saved without plugin data and i was ok,Quite worrying though,Thought i had lost todays work…

Hi Pascal,
It’s happened again.
Unlock doesn’t do anything
i tried saving without plug in that hasn’t worked either.

Hello - if you close the block editor and then Undo, does that get things back?
Can you tell me the exact steps to reproduce the problem?

@JohnM - should it be impossible to close a file with BlockEdit open?


Ahh sorry, All i did this time was exit the blockeditor.
I don’t know what i did previously i was in the zone.
I tried undo.
I ran audit,There are still blocks.
I am at home now,But will give you more info in the morning,UK BST 8:00

Just looking through things and it appears no autosaves have been happening since last update,Also no backup files either.
Both options are turned on in the options.

Any Help???

Hello - how are you determining this?


I looked in the folder and there are no autosaves after the 18th,I think that was when i updated.
I cycled the checkbox and they seem to be working again…
My major concern is this problem with the blockeditor wiping everything out,That put me back 8 hours today.
Still no backups though.

Hello - lets leave autosaves and .3dmbak files aside for another thread. I’d like to know how you get into the state where everything disappears - can you recreate that situation reliably and if so, how, exactly?


No i can’t like i said,I just closed the blockeditor.
Shall i send you the file?

@pascal You are allowed to close a model while block editing.

Just happend to me also. Should I just accept days of work is gone? Was there ever any solution presented?

Hi -
Rhino 5 and early builds of Rhino 6 had a bug where the BlockEdit command would write bad data causing loss of data. The problem of writing such bad data was fixed in Rhino 6. It is not possible to prevent reading files with bad data and, as such, opening an old file in the latest Rhino 6 or WIP 7 will still lead to loss of data.

Has any solution ever been found for this?? It keeps happening to me and ruining tons of work (my autosave is also not working properly). Randomly I will close a block, and everything disappears (with the exception of hidden objects, oddly enough. Those still appear when I enter “show”). Working in Rhino 6, so it shouldn’t be related to problems the thread mentions about Rhino 5.

Hi Hannah -
Please run the Rhino SystemInfo command and copy-paste the result here.

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Commercial, build 2021-08-10
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-LBAD5R4

Computer platform: LAPTOP - Plugged in [23% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 9-6-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Users\Hannah\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.20191.1418
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

What is the status on this issue ?!?!?!?
Just lost my project - and my sanity