Download install trial version Rhino 7

I downloaded and installed the trial version of Rhino 7 but after I opened Rhino the views were black and the program is unable to be used.

Your video drivers are probably horribly out of date. Run the command “SystemInfo” in Rhino and post the results here.

Thank you for your reply!

Yes Your driver’s are 5 years old. Please download the latest from the manufacturer website. This should solve the problem

Total Video Memory 1 GB…So this will not get funny.

The Intel HD 3000 is not a supported GPU.
It is ancient.
For V7, your only option is to go into Options > View > OpenGL, and drag the slider to the left.
This will disable some of the display features that use OpenGL, but that old GPU will never work well.

If you’re serious about running Rhino, you’ll need a computer that meets Rhino System Requirements. That 10 year old computer never did.

Should Rhino detect this condition of out of date systems (over 5 years) and issue a warning to the user gracefully instead of creating misunderstandings ?

The apparent number of users who are likely to get that popup then come here asking why they got it would be the reason not to issue it…

There are so many combinations possible, it would be hard to do reliably. For example I have a couple of 9-10 year old computers - HP8560w and 8570w with 2Gb Quadro 2000/2000M’s - on which Rhino V7 works OK for basic stuff. The video drivers can’t be updated anymore but Rhino V7 still runs reasonably well for what I need it to do with those machines.

We’ve discussed that and I (we) don’t think so.
We make the Rhino System Requirements easy to find.
We help people understand what those specification mean.
Rhino will run with the OpenGL essentially turned off (slider). It certainly does not run like we designed it to, but maybe that’s okay for an individual user’s needs. I don’t think we should be making that choice for them.
If someone has no clue what any of those specifications mean, then they will learn and hopefully it will not be too painful.

Rhino can’t detect the “Black viewport” condition and at least suggest the option change or even switch the OpenGL off ?

Absolutely correct,
I use a 15 year old computer, RH7 runs through the desert without much difficulty.
And the best power consumption in this unit is always under 100 watts in total.
Replacement for the pc unit cost 30 bugs :smiley:

Other unit here with Quadro 2000M worked, but without GPU rendering.

Rhino builds the display pipelines based on what Windows and the display driver tells it is supported. Rhino issues the display call and Windows and the GPU driver fail and you see a black viewport. There is no notification or anything to detect. You see the botched result of the setup. Rhino can’t tell if the driver is lying about it’s capabilities or not.

The old way to turning OpenGL off was disabling the hardware driver in the Rhino configuration.
As of V7.7, the OpenGL slider pulled all the way to the left essentially does the same thing.

When Rhino detects “stale” display drivers, a message is sent to the Notifications Panel. That was our compromise solution to issuing a warning without causing a bigger issue.

Additionally, Jeff made some huge improvements to SystemInfo. As an example, if you are lucky enough to have a nice Desktop with a good GPU, but misguided enough to have not attached a monitor to is, so are not really even using the good GPU, we tell you that.
I can’t tell you the huge number of systems, many company IT issued, that are misconfigured in this way.
“We couldn’t find the right monitor cable so we used what we had.”
Are you freaking kidding me?