Display Text in ShapeDiver Viewport

Hi guys,

do some of you know how to display some text in ShapeDiver viewport?
I’m looking something similar to Point List component. I’ve got some points I want to display, I tried text to curve > boundary surface > SDdisplay but I found out that SD it’s not supporting that component of squid (even if I’ve downloaded Squid for SD).

Thanks homies.

There are three ways to display text in the viewport, depending on what you want to do:

  1. Use ‘Text Tag’ (2d tags), which seems like what you are trying to achieve when I look at your screenshot.
  2. Use ‘Text Tag 3D’
  3. Use a plugin or script that converts text to curves and/or surfaces. The ‘TextCurves’ component from Squid should work, what problem did you experience? There are different options, but we usually share the script below which does both and provides many options for the font.BakeText.gh (20.0 KB)

Thanks Mathieu!

Options 1/2 should not work because you cannot connect them with a ShapeDiverDisplayGeometry, am I wrong?

Options 3 it’s perfect. Small suggestion: I think next time you could also add “plane” instead of point, so that someone could decide a point and the plane in which he wants the text.
But with an “orient” component I solved everything!

Thanks a ton!

You don’t need the ShapeDiver display components when using text tags, they are interpreted and displayed out of the box in the online viewer. In fact this is how most users do it :slight_smile:

I see. Now everything is clear ahah thanks! :slight_smile:

I’m having issues getting the Text Tag 3D to appear in the model. I’m getting the text size and color to show up in the parameters but I’m not seeing the text getting displayed.

I also opened your C# node but there were several errors upon opening. Is there an easy fix to the code?

About the C# node: there are major differences between Rhino 5 and Rhino 6 regarding text objects. This C# script is written for Rhino 6 and I am guessing you are using Rhino 5.
There are alternative solutions for Rhino 5, the problem being that our servers for the Free accounts run Rhino 6, and will therefore not be compatible with those.

As for the Text tag 3D problem, I need a bit more information. Could you share an example definition which produces the bug?