Display Switches to Wireframe


#1

Over here with latest WIP on polysurface-heavy models with many objects, the model always switches to wireframe on view rotation (from shaded or rendered) so hard to judge the improvement. Card specs below. It works like that with and without the tesselation ON.

NVIDIA Corporation
GeForce GTX 980 Ti/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 376.53
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 12-29-2016
Driver Version: 21.21.13.7653

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB


New V6 Display Faster: GPU Tessellation
(Steve Baer) #2

This sounds like
https://mcneel.myjetbrains.com/youtrack/issue/RH-39235

which Jeff fixed today.


#3

Steve,

With the latest WIP the display does not switch to wireframe anymore, but there is a new glitch over here: after view change (once the change stops and zoom or RMB is released) the curves/edges in Shaded and Rendered modes would ‘blink’ - dissapear for a second and then redraw; sometimes they don’t redraw and just disappear.

It also happens sometimes on object selection, viewcapture and restoring namedview.

–jarek


(Steve Baer) #4

metioning @jeff since he worked on this issue and may have an idea of what the problem may be.


#5

Steve - with more testing, it only happens when there are blocks in the scene.
Once I hide them, all works fine. I know Block display is being worked on… would anything be more helpful to show the problem or should we ignore it for now until block display code gets refined ?

-j


(Jeff Lasor) #6

@Jarek If possible, I’d like to see exactly what it is you’re talking about…either via an example file, or possibly a screen recording. It might be something that is specific to your config, or something easily reproducible…but I’d rather not guess at what’s in the scene, and use the exact model you’re using.

Thanks,
-Jeff


(Steve Baer) #7

Since this is block related, I may have this fixed on my computer right now. Jeff, you may want to sit tight on this.


(Steve Baer) #8

Bug filed at https://mcneel.myjetbrains.com/youtrack/issue/RH-39965


(Dan Belcher) #9

RH-39965 should be fixed in the latest WIP. Please give it a try.