Curves / Edges not displayed in all viewports (apart from pen & artistic)


#1

I have a problem where upon completing a drawing operation the curve disappears and is invisible when not selected in all “normal” viewports (i.e. apart from pen & artistic).
Upon selection a polyline is shown as if being in “POn”-Mode, not highlighted yellow.
Upon selection a volume just shows the faces without vertices.
When locking, it “freezes” the “POn”-Mode and grays it out, but upon “unlocking” and “deselecting” the lines disappear again.
(also happens in “opened” files, not just new ones.)

I am running a Windows 7 64-Bit system with an nvidia GeForce GTX 660 Ti graphics card.

I tried to make a video to make sense of this all.
https://we.tl/lmAhEYXFz5

looking forward to working with v6!
thanks for the help, and good night.


(Brian James) #2

Can you check your Display panel to make sure curves and surface edges are enabled in Wireframe mode? If you click the bottom button in the Display panel you can reset the mode to defaults in Options as well.

Any luck?


#3

@BrianJ
Thanks for you answer! Sadly it doesn’t change anything.
Please find attached a screenshot with all the checkmarks.
tried turning them off, tried changing edge thickness and color reduction, to no avail, sadly.

I checked every single mode, edges and curves are all enabled where they should be.

Weird. ^_^’


(Steve Baer) #4

Try disabling “GPU Tessellation” on Rhino’ OpenGL options page. Does that make a difference?


#5

@stevebaer
that worked! thanks!

can you quickly explain what it does? just out of interest :slight_smile:


(Steve Baer) #6

There’s a bug in your OpenGL display driver where it is not only failing to support a certain feature for drawing, it is not reporting that this feature is failing. I would check to see if an updated driver exists for your GPU. This is the first I’ve seen the bug occur with nvidia so I’m hoping that an updated driver will fix the problem.

GPU tessellation is an optimization we use to draw wires faster.


#7

@stevebaer Thanks, will do; will report here in a minute.


#8

@stevebaer

Updated my drivers for my NVIDIA. But upon turning GPU Tesselation on, it reverted back to not showing wires. Sadly.
Any ideas?


(Steve Baer) #9

Did you restart your computer after updating the drivers?


#10

@stevebaer yep. To no avail, again.
Funnily enough I opened another file and all dimensions, text and dots are shown fine.
just edges and curves not. I do not have the issue with meshes, I just found out. They display just fine as well.


(Steve Baer) #11

Edges and curves are all that we use GPU tessellation for.

@jeff do you have one of these graphics cards (GeForce GTX 660 Ti)? It would be interesting to see if you get the same results.

@swah I would recommend just keeping GPU tessellation off for now.


#12

I’ll keep it off.
I’ll try it on my Laptop as well and see what happens there. Different graphics card and such.

Thanks for your help, everyone! I’ll report back.


(Jeff Lasor) #13

@stevebaer Unfortunately no, I do not. I can pick one up if you’d like… But past experiences tell me that the card I get will most likely work.

@swah What is the exact make of your card? I know it’s a GeForce GTX 660 Ti, but who is the OEM? EVGA? If you have a link to the produce (i.e. Amazon, NewEgg, etc…) Then I know I’ll be getting the exact same card. The problem with just picking up a GTX 660, is that OEMs have their own flavors of cards and overclock and/or tweak them for VAR purposes. So a link to your exact card would be the best path forward.

Thanks,
-Jeff


(Steve Baer) #14

I know the feeling; some of this stuff is just so darn hard to repeat and even if we can repeat it what do we do when the driver reports no errors for a compiling and drawing with a certain shader


#15

It’s an EVGA, an EVGA3GB D5 X GTX660 Ti SC+ Backplate R to be precise.
Hope this helps.

It’s a fairly old card… bought it 2012.

it’s that one exactly.


(Jeff Lasor) #16

Ok thanks @swah… I have a similar EVGA GTX 680 here… I will see if it reveals anything…

-Jeff


(Jeff Lasor) #17

@swah

Just to make sure…which dirvers did you just install? I’m trying things out on Win10 first, then I will try Win7.

Thanks again,
-Jeff


#18

I updated the drivers via the device manager…


(Jeff Lasor) #19

@swah,

Sorry, I wasn’t very clear with my last question… I’m just want to confirm which version of the drivers you’re using. I have 388.31…just downloaded them.

If you go into Rhino and go to Options->View->OpenGL, you should see the driver info (assuming it’s working for you).

Thanks,
-Jeff


#20

Driver Date: 1-18-2013
Driver Version: 9.18.13.1106

…whoopsie. give me a second.