Display questions


#1

Several questions about Artistic and Pen display modes -

  1. In both of these display modes the background is locked (i.e. - the option to choose another image file is greyed out) - is there any way to override this and choose another background?

  2. The background shows through the objects in Artistic and Pen. I can see why that should be the default - in order to achieve the look of pen on paper (or parchment). But is there any way to alter that behavior so, for instance, the background could be a 2 color gradient but the objects would be another color? I know I can change the background and object color in shaded and rendered mode but my client likes the look of the line drawing of Artistic and Pen but wants me to show her more flexibility in background choice and object / background relation. I’d like to stay in the Rhino environment and not have to export to Illustrator.

  3. In the McNeel docs there’s a page called Display Modes. That page suggests that under View > Display Modes > at the end of the list, after Pen, there’s a tab for New. I don’t have New - has it been moved? Deleted? Disgraced?

Thanks in advance for any advice you can offer.


(Wim Dekeyser) #2

First things first,
When you select “Display Modes” in the left hand side of the dialog, you will get the list on the right hand side. Here you can copy an existing mode or create a new one. When copying e.g. Pen, you will be able to change the background image. Is this getting you any further?


#3

Thanks - that was embarrassingly obvious. I will play around with New and Copy today and see where it gets me.


(Brian James) #4

Hi arail,

You can change or remove the background image after you make a copy of the display mode.

Both of these modes were made from copies of the Technical display mode. You can make a copy of either and then choose to shade objects to get what you’re after I think. Here’s a display mode file you can import too which I just made…

NewPen.zip just unzip and import the ini into the display mode options.


#5

Thanks Brian - that’s very kind of you.
The mode is beautiful and should be elevated to the status of a standard display mode (maybe called Brian’s Gig?)
I just got in and started playing around with it but haven’t figured out what’s happening with the background.
Reduced size JPG attached.
Apologies again if the solution is obvious - I am, and probably will remain forevermore, a newbie.


(Wim Dekeyser) #6

Looks like you are using an image with a gradient as background that gets tiled?
Gradient is an option that you can use:


#7

That’s what’s got me confused. The background is a 2 color gradient and I only see the banding effect when printed. The background looks fine in the detail and when Print Preview is selected.


(Brian James) #8

Hi arail,

Thanks, I actually made the Artistic and Pen modes while we were finishing up Rhino 5 and our developers were kind enough to include them in the default install. I’d really like to start swapping display modes with users and hope that this will be possible soon in some sort of gallery on www.Food4Rhino.com which is run out of our European headquarters in Barcelona.

You’re print issue here looks like a driver specific one for the printer. I’d suggest looking for an updated printer driver as a first step to solving it if you want to print directly. The fastest approach though and the one I’d go with is to print to a png image file with the settings shown below…

Then print that after laying out the image in a presentation or using the default app for the printer itself. Let me know the printer model though if you can and I’ll test to see if happens here too with the makes/models we have.


#9

Sorry, I wasn’t clear - I wasn’t printing a hard copy, I was saving as a PDF. I get the same banded effect using Adobe PDF & CutePDF. And I get the same result saving as a PNG. The attached image is a PNG using the settings indicated above and saved as a JPG and reduced.

I’m mystified.


Rendering issues
(Brian James) #10

Hi arail,

Thanks for explaining more. Can you try this pdf driver please? http://www.pdf995.com/ Restart Rhino after installing the driver and it should be in your Print options within Rhino. I would also suggest updating your graphics card driver. Go to the manufacturers website to do so as this might be involved here. Can you also tell me what GPU you have in this computer and the date of it’s driver? This information can be seen within Rhino in Options>Rhino Options>View>OpenGL


#11

I will have to wait for the IT guy to update this driver at work. I will update the drivers on my home computer when I get in this evening and report back.

PDF995 - same banding effect.
Both work and home computers - cpu: i72600K / gpu: nvidia gtx series

still mystified


(Brian James) #12

Hi Arail,

I just helped another user that was experiencing the gradient banding issue when printing. He sent in a file and I could reproduce it here. I then found a work around and wanted to let you know as well…

  • Make a new floating viewport by dragging the name tab of the perspective viewport off towards the command line.
  • In object properties change the width to 612 pixels and the height to 792. This is the aspect ratio for 8.5x11.
  • Then use the command “-ViewCaptureToFile” the “-” is important. This will allow you to pick a location for saving the image file via the command line.
  • Next in the command line set the width to be 2550 and the height to be 3300. This is the aspect ratio of 8.5x11 at 300 dpi.