Background color for pencil mode covers design

Hello Everybody,

I have a problem with the Pencil mode (crayon?) : when I try to use it I get all sorts of funny background colors, either very bright or very dark instead of the normal white I want .

I just updated my graphic card, and I still have the same problem.

Can someone help me ?

Thanks a lot in advance


Do you mean the Pen display mode? Post an image of what you’re seeing please and also confirm the version of Rhino 5 is the latest and that you are using the default settings for the display mode.

Hello Brian,

Did you receive my reply by e-mail ? In case you did not I confirm that I always update my Rhino 5 version when there is a new release. I am also using default settings for the Pen mode.

I tried to change the layers to get better results , but it does not work. Here below 2 situations I get, one with a black layer, the other with a blue and a red layer. I can also come up with a bright yellow (especially if the objet is selected, but not always) or a strong red.

I am eagerly looking for any suggestion helping me solve this problem.

Thanks a lot for your help



Sorry, no, I did not get your reply by email. It looks like the background image installed for the Pen display mode is not being found on your computer. I’m not sure how this could happen if it was working prior to updating the service release. Can you try making a copy of the Pen mode via Options>View>Display Modes? Then you will be able to edit the background image used in the copied mode. I’d be interested if using any image at all is visible as the background in the copy of the Pen mode. This will tell us if it’s just a missing image file or if the technical modes are not displaying correctly on your GPU and driver.

Hi Brian,

I am not sure I understand what you are asking for. I enclose a picture of the options menu for Pen mode, and funnily, there is no access to the background picture. .

What do you mean exactly with making a copy of the Pen Mode ?


Click on where it says DIsplay Modes on the left of the Options dialog. You can then make a copy of any mode. At that point you’d be able to edit the background image in the Copy of Pen mode.

Sure, this is where I went to make the picture I sent you .

I do not understand how to proceed to make this copy. If I try to press any key I get a ring saying I am not allowed to.

How do I copy the mode and where do I put the copy ? Can you explain ? Doing this is completely new for me, so do not hesitate to describe all actions. Thanks a lot.


Sorry this is confusing. Here’s a screenshot of the Options page and the order in which you’ll need to click.

Any luck?

Thank you Brian. I was able to make the copy of the pen mode, and indeed I have access to the image file. Trouble is I do not succeed in changing it. Can you explain step by step ?

Herewith screenshot of the option dialog box. There is something intriguing : shaded appears in blue. Is this normal ?


If a display mode name is listed in blue it indicates that it is not using the default settings.

To change the image background for the pen mode, click the “…” to the right of the “image file name” field. This still may not display in your copy of the pen mode but it will tell us if your system can use this display feature of Rhino 5. If assigning a new image here doesn’t display an image in the background of the copy of the pen mode, post a screenshot of Options>View>OpenGL please. If it does display an image, then the image installed with Rhino likely wasn’t for some reason. It might be an incomplete install of Rhino.

Here is the screen shot of the OpenGL


If you don’t have “accelerated hardware” checked you won’t get display abilities like shadows in rendered or technical modes. This might cause the background image to be missing too in Pen mode which is a derivative of Technical. Rhino will automatically disable this if it detects that your GPU is an early Intel HD series. Check the box for advanced hardware and see what it reports as your GPU. Post a screenshot of the OpenGL page after that too please if you still don’t see an image background in technical modes… like pen.

Thank you soooo much, Brian !

It works, for Pen, and for Shaded, which I had not used for a long time as I had pictures with a kind of metallic appearence.

With best regards