Display problems with retina 5k screen. Pixellation instead of a full resolution window

display
retina
imac
scaling
pixellated

#1

Hi there,

Rhino V5 had been going great with my 5k retina screen, but the display seems to have changed, making it look pixellated.

When it starts, it’s as if I’m only getting 2560x1440 pixels on a full screen window display. It’s looks like the antaliasing is off (or worse). I have uploaded a screenshot of how it loads.

Then when I press a shortcut key like ctrl-o for open new document, the window shrinks to 1/4 size all off a sudden, but then it looks sharp.

Obviously I can’t work that way, so when I go to maximise it, the scaling is all wrong and I can’t see the command line options (see pic#2).

I’m running Rhino for windows on an imac retina with bootcamp.
I’m not sure what caused it, maybe an automatic graphics card update.

The Rhino WIP loads perfectly, so Ive been using that instead as it has better scaling of icons (but it just expired).


#2

Sorry, the last pics are around the wrong way and can’t edit the original post for some reason…

Here is the 1/4 view:


(Pascal Golay) #3

Hi Leslie - please copy and paste this command:

testToggleFileDialog

into Rhino’s Options > General page where it is labeled 'Run these commands every time Rhino starts
Then close and re-open Rhino - does that work better?

-Pascal


#4

Ah!

That definitely stops it going to 1/4 size whenever I open a new file.
So the icons no longer appear all scrunched up. I sincerely thank you for that. At least I can work now.

However the pixellation is still there with Rhino v5. I think it is because my windows scaling is set to 200%. It’s really like the application is running in 2560x1440 when it should be 5120x2880. That is not how the scaling should work.

When windows scaling is set to 100%, everything is crisp (but smaller). Of course, this makes all the text on the rest of my desktop positively minute and it’s harder to do everything else I need to do. It’s strange how the new Rhino WIP copes with this setting too, it is unaffected… (my WIP is not working at the moment though).

I am not sure why other programs look crisp? Firefox, thunderbird, adobe programs.
On my computer, this 200% scaling setting just seems to just make Rhino V5 half the quality. Is there a way of disabling windows scaling (to make it 100%) for only some applications? Maybe that is more a windows issue?


(Dale Fugier) #5

Hi @LeslieDeanBrown,

Does this help?

https://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

– Dale


#6

I eagerly applied the suggested Windows 8.1 fix:

Check “Disable display scaling on high DPI settings”

And it worked!!

Thank you thank you thank you thank you thank you