Display quality for retina Macbook pro


#1

Well I got a new job and they gave me a new 15" retina macbook pro. It is the nicest computer I have ever owned, on the mac side the display is just crazy beautiful to use, on the windows side (bootcamp, never virtual) it is pretty weird.

Windows 8.1 actually helped a lot but rhino still looks pretty bad. By default it scales the program. The icons look great but the text objects are way to big. You can change the text size by type (“title bar” “tool tips” etc) in the control panel but none of those settings effected the text inside of rhino. Of course I can change the command line font and size but that does not effect other text…

help?!


(John Brock) #2

It’s not going to be very good.
The best advice I know of is to set Windows to 150%-200%
Then set Rhino’s toolbar button size to Large.

Several people here in the office have MBP Retinas and use an external monitor.

Eventually Windows will get uber high resolution screens, then they will build named Desktop schemes that work.

Eventually Apple will get touch screen iMacs and MacBooks too.


#3

I didn’t find it that bad really, love the extra view-port real-state

Only things bugging me are tabs and their text sizes on view-port name tabs.

Any way to play with that?


#4

Bump


(John Brock) #5

With a System Registry key addition and copying a manifest file to the folder where 64-bit Rhino V5 lives, you can fix the small icon problem on high resolution monitors.

The details are in this new FAQ support document:
http://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

This also fixes the same issue for Grasshopper in 64-bit V5


#6

Hi John_Brock,

I have done what is written in the FAQ support Document. But nothing has changed, even after a restart of the computer.

(Rhino 5 for Windows 10 using bootcamp on Apple Imac 4K retina 2015)

Thanks for your help.

Laurent


(John Brock) #7

So the registry key is where it is supposed to be and the manifest file is sitting in the 64-bit Rhino System folder with the correct name?


#8

My apologies, I copied the file in the x86 part. And I was running 64.
It worked now ! Thank you for your help !


(John Brock) #9

No worries. It had to be one of the two.


#10

Hello,

I have had the same issue, and I have copied the file to my x64 Rhino 5 System folder. Everything is working fine, the text and icons have indeed increased. To such an extent that the Rhino resolution is… bad. I have no other words for it. It’s pixelated. Does anyone know a way to find a middle ground? I hate to sound like Goldylocks here, but it would be amazing if there was a way to get the resolution “just right”.

Thank you for your help!


(John Brock) #11

Are you running Windows 10?


#12

Thank you for the quick reply!
Yes, I am running Windows 10 on a 2015 MacBookPro Retina.
I’ve currently reverted to the previous settings - the resolution was too shoddy. And there was a zooming issue with the grasshopper too, where I needed to zoom in a lot to see the information about components already on the canvas.


#13

hi @John_Brock,

I’m having a similar issue, that was mostly fixed with R5.14. However, there are a few oddities that you should probably be aware of.
Menus and Command Line are now truncated:

Properties display is also inconsistent (all Flamingo related items display yuuge. It seems like Flamingo is reacting to .14 differently than Rhino):


Elements at bottom of screen are also tiny:

One more screen cap showing everything:

Aaaaand, when I go to open a file (a quick check shows that Rhino is the only app that displays text so large in the open dialog - PS and Chrome display normally):


edit: after restarting Rhino a few times this seems to have cleared itself up…

Edit 2: mouse over buttons (set to large) reverts them to small (still set to large in Properties)

FWIW, I’m still running monitor 1 at 200% as otherwise I would need a magnifying glass to view the Windows toolbars. I’m running R5.14 (updated this morning) in Windows 10 on a bootcamped 2016 iMac.


(John Brock) #14

What edition of Windows are you running?

What are your display settings?

What are your Rhino shortcut compatibility settings?


#15

Hi @John_Brock,

Here’s my settings:

The one major difference I see is that I do not have the option to override high DPI scaling.

-b


(John Brock) #16

Yes you do, but you’re using the earlier version of Windows so the U/I is different.

For you, on the shortcut properties, see if checking the option for “Disable display scaling on high DPI settings” fixes your problem.

BTW - the “About your PC” Windows tool will give you the version number. I suspect you’re running (1607).


#17

Voila!! Much better!
Thanks, John.
everything looks better now, the only oddity is at the footer:


(John Brock) #18

In Rhino Options > Appearance, set your “Text size” to 9.


#19

It is at 9. I also tried setting it to 10, however this did not cause the ‘cell’ around the text to resize.

-b


(John Brock) #20

Try 8 or 7. You might have to restart Rhino depending on how “responsive” your display drivers are.
You should also check and see if Apple has a Bootcamp driver update for you.