Display Modes Not Working

v6_display

(Jeff Lasor) #24

…and did you reset them to their defaults? And did the reset sick (i.e. they’re sill not blue when you go back into the options)? As far as I can tell, the images look correct…although Rendered looks like it’s missing the ground plane and shadows are off…but that may be because I told you to turn them off…but from the pics, it looks like Rendered mode and Technical are working (i.e. they’re not jumping to wireframe as you mentioned they were before)… Is that not correct?

And by “worse” I’m assuming you installed the drivers Nathan linked to and now things are worse?

Is this something that started happening to you recently? Or did this start happening the first time you installed V6? In other words, has any recent V6 Service Release caused the problem? I’m wondering if we’ve introduced some issues in the latest SR… I see you’re on SR4 … was this happening in SR3? SR2? SR1? SR0? …

Given what you’ve said, your display modes sound like they’ve somehow gotten corrupted…which could really start messing things up depending on what kind of corruption is present. I guess the next thing I would like you to try is to completely wipe 6.0 off your system and start over from scratch…no customizations, no display mode tweaks, just pure straight out-of-the-box Rhino V6… and see if you’re still having these issues.

If you’re willing and have the time…Please:

  1. Uninstall Rhino V6
  2. After uninstalling, there are still some residual files left in %APPDATA%\McNeel\Rhinoceros\6.0. I would delete the entire folder. This usually expands to something like “C:\Users\YOURNAME\AppData\Roaming\McNeel\Rhinoceros\6.0”… The easiest way to get there is to just type %APPDATA% in the file browser (see image), hit enter and then navigate to the McNeel folder from there… Note: You only want the “6.0” folder, do not touch any other Rhino folders, as they are for your other versions of Rhino.

image

  1. Re-install V6, and do not make any kind of customizations or tweaks…
  2. Begin your tests.

Thanks,
-Jeff


(Jeff Lasor) #25

Hi @milezee, I just saw this…

So, you were on V6 SR4 and things were working fine? And then from one day to the next the same V6 SR4 was exhibiting these problems? In the other words, the exact same program used to work and now somehow does not?

If that’s the case, have you updated to any Windows Update recently? Have you installed any other software or hardware devices that may have changed your system confifuration?

Thanks,
-Jeff


#26

Hi Jeff, yes Rhino was working ok. I have done some Windows updates earlier today, and have been running V6 since, it seems much better today, display modes seem to be ok, will see how I go with it before uninstalling and starting over.


(Jeff Lasor) #27

Ok thanks for the update…

-J


#28

Jeff, display modes are playing up again, they have disappeared from the drop down menus in the viewport and display tab in the r/h tools panel, and if I go to the Options panel there is no display modes either

:frowning:


(Jeff Lasor) #29

@milezee

And so what has transpired between now and then? Have you made any changes to display modes? Have you tried importing older display modes from previous versions? Something has got to be causing this, as I just don’t see this happening from one minute to the next without some kind of action being made… ???

-Jeff


#30

I did some Windows updates, it seemed ok, so have continued to use V6, I had been working all day on multiple models, lots of copy & paste, lots of Layouts using Pen Mode And Technical Mode from Make2D. Then suddenly a tiny screen glitch, then bang, display modes gone, disappeared from drop down menu, disappeared from Options, just Wireframe left, which is pretty useless :frowning: .


(Jeff Lasor) #31

And restarting Rhino does nothing? When Rhino sees that there are no display modes, then it recreates all the built-in ones from scratch, with their defaults… If that’s not happening, then Rhino still thinks they’re there, but some kind of corruption is preventing them from displaying.

Something sounds like it’s corrupting your display modes (over time)…I just don’t know what that would be… Do you have any 3rd party plugins that manage/tweak display modes?

I would still go through the steps I outlined above, about deleting V6’s settings completely off your system and see what happens.

-Jeff


#32

I use 2 monitors, have Vray and Section Tools installed, I can’t think of anything that would be interfering with the Rhino displays. I shall try again tomorrow, if it doesn’t;t improve I will delete and re-install. Jeff I’m currently using the V6 Eval, will this affect deleting and re-installing ?


(Jeff Lasor) #33

As far as I know, it will only cause Rhino to reset everything to its defaults…It should have no impact on the Eval.

-J


(Jeff Lasor) #34

Being that VRay for V6 was just released, I would try disabling that plugin for the time being, and see if things continue to work or still become corrupted.

-J


#35

uninstalled/deleted everything, display modes seem fine, one issue I have is that there isn’t any templates installed, in fact there is no Localization Folder in V6 at all :frowning:


(Nathan 'jesterKing' Letwory) #36

Can you do a repair of the installation? (First close Rhino, then rerun the installer and select Repair). Once repaired Rhino should realize the templates and localization folders.


#37

Hi Nathan, where would the Rhino Installer be located ?


(Nathan 'jesterKing' Letwory) #38

You should be able to get there through the Apps & Features part of Windows.


#39

tried the repair, still no localization folder :frowning:


(Nathan 'jesterKing' Letwory) #40

@brian, you may want to ask @milezee the specifics you need for this.


#41

Nathan, not sure if this is relevant, but I just tried using Arctic in a detail on a layout, perspective view, it just sent my machine into meltdown


(Nathan 'jesterKing' Letwory) #42

Well, meltdown sounds bad, @DavidEranen or @jeff know better about Arctic.


(Brian Gillespie) #43

Hi @milezee Rhino extracts the localization folder on startup if it sees that the running Rhino is newer than the one that has already been extracted. To see that, it looks in a registry key. I’ll show you how to delete it and cause Rhino to re-extract the localization folder:

  1. From the Start menu in Windows, type regedit then pres Enter
  2. Browse to HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Install
  3. Delete the rhiexec folder

Now, start Rhino and you should get a localization folder.