Default Display modes not working properly


(Gary) #1

I just updated to the latest version Rhino 6, 6.5.18149.14421. My display modes are behave VERY different and I cant figure out how to restore them to the normal defaults. For example, the shaded display mode looks transparent. the other display modes also behave very differently. I’ve tried going to View>display options>view>shaded - restore defaults with no effect.

Below is what i expect to see for a shaded display mode (from R5)
image

This is what I get now:
image

Here is my system information:

Rhino 6 SR5 2018-5-29 (Rhino 6, 6.5.18149.14421, Git hash:master @ 39e73a6a93c18c92e40c05cb323c990246a30569)
Licence type: Commercial, build 2018-05-29
License details: Cloud Zoo. In use by: Gary Lewandowski ()

Windows 7 SP1 (Physical RAM: 10Gb)
Machine name: RHINOCAD

AMD RADEON HD 6450A (OpenGL ver:4.1.11079 Compatibility Profile Context)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Driver Date: 11-23-2011
Driver Version: 8.892.2.3000
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2018 for R6\RhinoCAM 2018 For Rhino6.0.rhp “RhinoCAM 2018 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2018 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #2

@jeff you may want to take a look at this one.


#3

Driver date 2011?


(Nathan 'jesterKing' Letwory) #4

You may find a newer driver here https://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows%207%20-%2064 - but note that your GPU is considered to be legacy by AMD, i.e. no more newer drivers. But still there seems to be one from 2015.

Before considering updating the driver make sure all requirements are met, as laid out on the linked page.


(Jeff Lasor) #5

Hi @gary3,

When you say “updated”…does that mean you had 6.4 installed before, and it was working? So basically, we (I) broke something in the 6.5 release? Or is 6.5 the very first version of Rhino V6 you’ve ever installed?

Here’s what I would try if this was happening to me:

  1. Close all Rhinos (all of them, including any 5.x you may have opened)

  2. Start Rhino (do not load any file or create any kind of geometry)

  3. Immediately go into Options->View->Display Modes

  4. Select a display mode in the right-side pane and click the “Delete” button on the bottom of the dialog.

  5. Repeat #4 until ALL of your display modes are gone (see pic).

  6. Close the dialog (click the OK button), and then close Rhino

  7. Start Rhino again…

Now see if your display modes are still acting up. If so, then we’re going to need to run some diagnostics on your system…my hunch is that certain shaders are failing to build successfully, and Rhino is falling back to the most basic mode of operation (Wireframe)… But let’s just see what the above steps produce before I speculate about anything.

Thanks,
-Jeff


(Gary) #6

Ill give this a try before i try updating the graphics driver. I’m trying it now.


(Gary) #7

I just finished deleting all of the display modes and now I get a shaded object BUT there is still something odd going on as the object is orange not grey per the layer color. see below:

image


(Jeff Lasor) #8

Very strange… What do the other modes show using the same box scene?

2011 drivers are somewhat old… So I highly recommend updating your drivers to the latest version you can… V6 uses your video card to its fullest extent possible, whereas V5 hardly uses it at all… so any issues with 2011 drivers will show up far easier and sooner in V6 than they would in V5.

The Shaded mode uses a canned environment map, and I’m wondering if something is going wonky with the texturing and EMapping, thus producing the orange color… What happens if you go into the Shaded mode settings an UNCHECK the environment map usage… see pic:


(Jeff Lasor) #9

Also @gary3, I still need to know if this was working in 6.4, or if 6.5 is the very first version of V6 you’ve installed… It’s important, because if we broke something from 6.4 to 6.5, then it needs addressing ASAP.

Thanks,
-Jeff


(Gary) #10

OK guys, I just updated the AMD driver to the latest 2015 version and it appears to have solved the display issues. I now get a correctly shaded object:

image. The other display modes all seem to be working correctly now (specifically Render).

Thanks for the timely help!!


(Jeff Lasor) #11

Cool! Thanks for the update…

-J