Rhino 6 display modes don't work

unhandled

(Inesbolivarrodriguez) #1

I just installed rhino 6 and the different display modes don’t work. When I select Rendered the model dissapears, Ghosted stays the same as Wired…
What can I do to fix it?

Thank you very much


(Wim Dekeyser) #2

It sounds like you need to update your GPU drivers.
Run the Rhino SystemInfo command and paste the results here.


(Inesbolivarrodriguez) #3

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 7 SP1 (Physical RAM: 7.9Gb)

Intel® HD Graphics 4000 (OpenGL ver:3.3.0 - Build 8.15.10.2712)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 3.3
Shading Language: 3.30 - Intel Build 8.15.10.2712
Driver Date: 3-26-2012
Driver Version: 8.15.10.2712
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 2112 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #4

You should at least update your drivers, they are almost six years old. You should be able to get your updated drivers here: https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000-for-3rd-Generation-Intel-Core-Processors

This should improve your experience. Note though that the Intel HD Graphics 4000 is quite old already. According some information I found (https://en.wikipedia.org/wiki/List_of_Intel_graphics_processing_units#Seventh_generation) your card supports up to OpenGL 4.0. I am not sure if that is high enough for full viewport support. @jeff or @stevebaer can probably tell you better what kind of performance you should expect with your card.