Display modes changing on their own

I was playing around with display modes and ran into what seems to be a bug. I tried copying “Technical” and editing its settings, but after reopening Rhino and modifying the settings some more the Display settings for “Copy of Technical” all changed on me. Some visibility types disappeared that are normally available for “Technical”, and the ability to adjust clipping planes showed up. I’ve noticed different display modes have different settings and the “copy of Technical” seemed to revert to the set of options that I’d find for “Shaded”. Is there a way to stop this from happening?

Additionally should “Technical” have the ability to control how clipping planes look? I was excited to see that the setting had appeared until I realized that I couldn’t control silhouettes/creases/ and intersections, any more.


Hi Ian - I do not know what to make of this , I have not heard of it before but it sounds ugly… I guess I’d start with setting the default modes to their default settings before copying them and see if that helps. I’ll see if I can reproduce but I am somewhat skeptical - we’ll see…


Try taking a Default Pen view and make a copy. Change some settings, like change the back ground to solid color, and increase the thickness of silhouettes. then click OK. Go back in and change some more settings. again click ok. Go back in and by this point the settings should have changed so that the visibility settings no longer have the option for silhouettes, and you now can control clipping plane objects.

Thats at least how I got it to change just before responding here.

Hi Ian - do you have more than one Rhino open when you’re doing this?


Nope, Just one copy

I am seeing that here as well - … and thought that it was well-known.

At any rate, I now made a copy of the RH6 factory-default Pen, did some changes (first background color, then naked edges, then real-time engine, then edges). I’m not sure at which point the available options changed…

The pipeline setting for the factory-default Pen is hidden from the user. Is that by design? I take it that is still Technical2D? When you make a copy, the pipeline setting is exposed to the user but is set to OpenGL without any other options. Is that by design? And if so, why bother?

Display modes that are brought in from RH5 expose the pipeline setting with the following options: Windows, OpenGL, and Technical2D. (Or perhaps that is only the case for “technical” display modes that are brought in from RH5?)

Still confused…

Here are some Pen-derived modes, showing that some have surface and mesh settings whereas others do not.

Ok - it looks to me like this changes from 6.0 to 6.1 (which is what I’ve been running) Going back to 6.0 I see the pipeline change as described and the bad things happen. i.e. it appears to work correctly in V6.1…



1 Like