Custom Display Mode randomly changes to use SubD settings

Howdy–I have been trying to create a custom display mode, but I keep running into a bug(?) that is preventing me from making it look how I want. To start, I made a copy of the “Pen” mode, and then started to go through and edit it to how I wanted. It was working fine at first, but as I was opening and closing the “Options” menu and tweaking it, the mode suddenly changed. When I opened the menu back up, the interface for the display mode had changed and added a bunch of new buttons/options related to things like “SubD” while getting rid of other buttons/options I had been using. Clicking “Restore to Default” got rid of the changes I had made, but kept in the new buttons/options, meaning I couldn’t just reedit the file since there didn’t seem to be a way to return to the true default. I tried to start over, but every time ran into the same issue, and it never seemed to be a singular change that made the difference.

Options & View before change:

Options & View after change:

Options & View after “Restore to Default”:

The change in this instance was turning on the “Shade-highlight selected surfaces and polysurfaces” option under “Objects”, however I had turned on this option on the first iteration of the display mode without it making any changes, so I do not think it is the singular cause. Also shown in the pictures are new subheadings under “Objects” that are in addition to the standard “Points”, “Curves”, “Lines”, & “Clipping Planes”.

I was eventually able to work around the issue by making all of the changes that I wanted to, exporting the settings to a file in a separate location, then closing the “Options” menu (at which point the Mode changed to have the new options), deleting the new display mode in Rhino, restarting the program, and then importing the custom display mode back in. Importing the mode seems to work–I was able to close the “Options” panel without the display mode corrupting, but going back in and trying to fine-tune again can cause it to bug-out, forcing me to reimport the files.

I mainly am posting this to inform about the issue, or to see if anybody else had run into similar issues with creating custom display modes. I don’t think it was any issue with any of the changes I made (again, I made no changes between the version I exported and the version that had the issue when I closed the tab), but if it was something I did, then I would like to know.

1 Like

Hello - is there a chance that your starting Pen mode was originally a V6 one?


No, this was a fresh install (last night) of Rhino 7 onto a new computer–I have Rhino 6 (and had had a custom version of “Pen” there) but I just upgraded to 7 and installed it on a separate computer, so I don’t think there would be any connection between the two.

I’m having the exact same issue… Every time I change a new or existing Mode it keeps changing the options in the settings, sometimes there’s options for SubD and sometimes there isn’t. This is becoming very frustrating as my PDF’s are showing a thick line weight on closed polysurfaces that I cannot change… it also forces a Raster PDF instead of Vector, even if there’s no shading… my drawings look terrible… any help here?

@mary @pascal has this been reported as a specific issue yet?