Display Mode(s) crashing file/becoming unresponsive

Hi All,

I’ve been running into an issue recently where my file keeps crashing/becomes unresponsive once I start using any other display mode besides shaded or wireframe. I am trying to use the rendered display mode to check the scale of textures/materials on the model before I fine-tune my settings in VRay to render.

Earlier this week it was working fine. Until I started to create some of my own display modes. I had a blue screen earlier this week too, and also an issue where my PC didn’t post (DRAM issue), requiring me to troubleshoot by removing my GPU and RAM. All seems to be working well now…

I’ve reinstalled Rhino and Vray a few times now to try and sort out the issue by removing them from %APPDATA% and registry key settings. But still no fix.

I’ve tested all the display modes on various other files, it seems to work as you would expect, and now I’m at wits’ end…

Any help or guidance is greatly appreciated!

Many thanks,

-S

SystemInfo Below:
Rhino 7 SR30 2023-6-12 (Rhino 7, 7.30.23163.13001, Git hash:master @ f695e494df78377a81b2b95edb99c6067e324b33)
License type: Educational, build 2023-06-12
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 6-8-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.23
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-8-2023
Driver Version: 31.0.15.3623
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

EDIT:Screenshots of Issue


image

EDIT2: Some troubleshooting/Screenshots
I’ve sort of managed to get rendered view to work. I did this by turning off the Vray sphere lights/ moving them to another layer and hiding them. The rendered. view as you would expect…

But now I’m running into an issue where if I rotate around my model, I get very weird ghosting effects, where the very start of the image is burned into the display mode. I can only get rid of this by turning the Sun ON and OFF. Once I turn the sun back on and rotate around the display the ghosting comes back…

Hi Sundeep -

Just to make sure, when you disable V-Ray in the plug-in manager and start Rhino again, does the problem persist?
-wim

Hi Wim,

Thanks for your response.

image
Lights are no longer vray sphere light instances.

Once I do the above, the problem still persists, albeit not as unresponsive as before. I can still select objects just not as fast and with a big delay. Panning/orbiting around the model is still an issue.

Reckon the issue might be down to the fact that my intensity is really high, (for artistic reasons) and as a result, it’s proving very difficult for the rendered display mode to calculate the amount of light being thrown. The light problem is less of an issue, but the Sun/ghosting issue is an annoying one, as before I start rendering through vray I would like to know where the position of the sun and shadows are going to be.

Thanks,

-S

Hi Sundeep -

I’m a bit unclear about what’s being reported here. The title says crashing / becoming unresponsive. I don’t see any crash reports from your account here, so is the issue only that things get slow?
And that this limited to that single file?

You should probably post or upload (Rhino - Upload to Support with reference to this thread) the model if this is not something that is reproducible with a simple test scene.
-wim

Hi Wim,

Thank you for taking the time to respond, I really appreciate it.

Initially, prior to some troubleshooting, the file was crashing and becoming unresponsive.

After the troubleshooting, I managed to get to a point where it is now just extremely slow.

Unfortunately still, however, I still have an issue with the Sun/burned-in shadow/image… Any solutions for this?

Many thanks again

-S

@sbagoan When unexpected things like these happen, one other thing you should try is to start a new fresh file, and import your file that behaves bad. Can you see if that has any effect in this case?

Hi @Gijs,

I hope this thread is still good to reply to 5 months later…

This is generally my first plan of action when I experience unexpected behaviour.

For the other issues listed above, I found solutions for or a workaround to let me continue with the project.

I still cannot find a solution or a fix for the ghosting issue and is becoming a massive hindrance to my work flow.

I am planning to upgrade to the Rhino 8 shortly, and if this is fixed already, please let me know.

Hope you and the team have a pleasant time off during the holiday and a good start to the new year.

Many thanks,

-S

Hi Sundeep -

That’s fine, yes. When so much time passes, though, it’s be good if you could post the updated SystemInfo data.

To be able to answer that question, we’d need to be able to reproduce the issue on Rhino 7 and then check if it still occurs on Rhino 8. So far, we haven’t gotten enough information to be able to reproduce this on Rhino 7.

As I’ve asked before but haven’t gotten an answer to, what happens when you go into the plug-in manager, disable V-Ray, and restart Rhino.

If so, and from your initial post in this thread (though I’m not sure how much of that still applies), it sounds like this is very file-specific. Please upload the file so that we can try to reproduce what you are seeing.
-wim