Rhino 7 crashes when I change the display mode

it keeps crashing when i change the display mode im not sure what the problem is i just got this pc its amd 6950

1 Like

Run the Rhino command “systeminfo” and post the results here.

Rhino 7 SR26 2023-1-9 (Rhino 7, 7.26.23009.07001, Git hash:master @ 92abcf7c453c78a236526390d91d0ac1f6779143)
License type: Evaluation, build 2023-01-09
License details: Cloud Zoo
Expires on: 2023-05-06

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon RX 6950 XT (AMD) Memory: 16GB, Driver date: 2-10-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 2-10-2023
Driver Version: 31.0.14001.45012
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 24247 MB

Rhino plugins that do not ship with Rhino
C:\Users\Eddie\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.3\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows”
C:\Users\Eddie\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ProRender\\ProRender.Windows.rhp “ProRender”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I guess first thing would be to see if disabling ProRender and the denoiser helps

it was still crashing when i didnt have them installed. i just got them thinking they would help

No, adding plugins isn’t going to stop crashing, only add chances for it.

Some older AMD cards have been having driver issues, didn’t know about current ones…you can try lowering the level of opengl support in Options->View->OpenGL

alrighty let me try that ty so much

just switched opengl to 2.1 worked alright but when i tried raytraycing it got really slow but didnt completely crash.

also i think i disabled the plugins but im not too sure

Raytracing isn’t OpenGl, it uses…whatever the equivalent of CUDA is on AMD, and yes it’s gonna be way slower, it’s actually ray tracing while OpenGl is a collection of hacks for simplified ‘realtime’ graphics dating back to the 80s.

ah i didnt know that. im still really new to all of it. thank you so much for the help.

Hi Ed -

It’s good that this got you on the road, but…
I would first try to set this back to “Max OpenGL” and uncheck the GPU Tessellation option on that page.
If that doesn’t work, and if you haven’t already tried this, please try “OpenGL 3.3”.

Apart from those settings in Rhino, I notice that you are running the latest drivers for that GPU. As Jim mentioned, we’ve seen older AMD cards (mostly RX 5-series cards) having problems with recent drivers. As far as I can tell, all of these were using late 2022 drivers, and we had reports of RX 6-series cards running fine on these. I would recommend downloading an October 2022 version of the drivers to see if those work on your machine with both GPU Tessellation turned on and max OpenGL.

1 Like

Hi Wim,

Thank you for your help but i wasn’t able switch the display mode without it crashing even after everything you suggested. :frowning: I ended up downloading a driver that was released 10/25/22 but it still crashed even when i had open gl at 3.3 so i decided to go back to the newest driver with open gl at 2.1. If anyone has anymore suggestions I am happy to try them all out. Thank you

Since you are on a desktop, see if you can replace that AMD card with an NVidia one. That’s the easiest way to solve your issues.

I didnt end up switching my amd card since i had just bought the pc, but i recently updated rhino and my amd driver so its been working a lot better. only thing was it turned black when i switched it to arctic on the display mode and i ended up having to restart rhino. but right now everything else with max open gl is looking a lot better. :slight_smile:

spoke too soon when i put render it also crashes :frowning: