Rhino 8 Crashing in Display

I am finding the same thing. I’ve had several projects in the last few months that the files continually crash randomly. I’ve tried updating NVIDIA drivers. Rolling them back. Using V-Ray as the renderer. Using Rhino Render as the renderer. All the crashes seem graphics related, but nothing that I can pinpoint. I just had to move back to Rhino 7 today as well, as the instability of 8 has begun to affect productivity.

@devind - All these crashes are a little different. In the cases associated with your resported crash we need more information. Can we see the results of “SystemInfo” run in Rhino on the machine crashing?

Sure thing:
Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Educational, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 7-11-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 4070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8188 MB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\packages\8.0\Pollination\1.46.0\Pollination.RH.Loader.rhp “Pollination.RH.Loader”
C:\ProgramData\McNeel\Rhinoceros\packages\8.0\LadybugTools\1.38.175\Ladybug.RH.Loader.rhp “Ladybug.RH.Loader”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRsceneImportForRhino.rhp “V-Ray for Rhino VRscene Importer”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

The Intel drive is a little old, so that could be updated. The Nvidia and Intel need to work in tandem.

The one crash report we have is display related with creating shadows. Can the crash be reproduced? Or is it spiratic?

Are there other email addresses that crashes are being reported with?

Huh, that is funny. I normally work in pen mode or shaded mode without shadows. I can’t seem to reproduce the crash. Sometimes it happens when orbiting the model. Sometimes when I’m drawing geometry. Always modeling in 3d. The model I’m working on isn’t even large or at all complicated…just a massing. I notice that the display is really jumpy though, and when I move to rhino 7 everything is smooth when I’m orbiting and moving around the model space. I’ll try to post more crash reports–I’ve honestly been pretty bad about doing that in the past.

Just a couple crash reports would be great. They do help a little.

Something to try is to turn off GPU tessellation in Options > View > openGL.

Of course if we had the files we could benchmark it ourselves on Rhino 7 and 8 and see what is happening.