Disappearing CPlane Grid


#1

Hello,

I’ve noticed something unusual when I rotate my view in perspective viewport.

Parts of the grid start to disappear as I rotate my view. All of it will disappear if I use set view to Plan.

However, if I introduce an object that lies on the CPlane or goes through it, then there is no problem.

I have to objects on the same layer to illustrate, one hidden from the other so you can switch back and forth to see what I mean.

I’m hoping there is a setting that can stop this behaviour so that I can rotate freely without loss of seeing the CPlane when the object is not on or goes through the CPlane.

I thought at first it must have something to do with clipping. But I get the same effect whether the object is closer to the viewer or further away from viewer relative to the CPlane.

Disappearing CPlane Grid.3dm (108.8 KB)


(Brian James) #2

Here’s a video of what I see with your model here…
CplaneDisplay.zip (5.4 MB)
If you see the Cplane grid disappear when doing the same, it sounds like a graphics card driver issue. See if updating your driver helps… see https://wiki.mcneel.com/rhino/5/video/troubleshooting if you need help with that.


#3

Hi Brian J,

Yeah, I get the same as you. But that is my point. The object you were viewing with is the object that goes through the cplane. If I switch to the other object that was ‘hidden’, that’s where the problem starts to occur.

I guess I should have put the two objects on separate layers so my explaination was more clear.

Thanks for taking the time to suggest a possible reason.

Edit: P.S. - Yes my drivers are updated - Something I do often check for.


(Pascal Golay) #4

Hi BabaJ - I do not see any problem with the grid here at all so far - do you see it clipped by a plane, visually - that is, part of the grid disappears in a straight line? That would be the camera clipping if you get it in this state, hit F6 and without changing the view in that viewport, look at the camera object in the other views - you should see the near and far clipping places as dotted rectangles.

-Pascal


#5

Hi Pascal,

Thanks for that. So it is a clipping plane ‘issue’ after all. Doing what you said I can see by ‘default’ it is setting the clipping plane to the object. I was assuming also that clipping planes were set ‘globaly’, but here it is set to pivot around the object.
And the Add Clipping plane command lets me change that to the current CPlane, so I always see it no matter how I rotate.

Thanks for the tip.