Serious CPlane issues

Hello,

I have been having issues for a while with moving the CPlane. I don’t know what Rhino setting must have been changed to have messed all this up. When I move the CPlane (All=Yes), my whole workflow gets messed up. The CPlane grid disappears, and I cannot move it again. See the pictures below:

How do I get back to my old setup?

Thank you.

Hello - check Options > Modeling aids and make sure Construction planes is set to Standard. Any better?

-Pascal

Hi Pascal,

It is already set to Standard construction planes.

Best,

Evan

Hi Evan - what is happening is the plane is turned edge-on to the view - that is why you don’t see the grid and why moving it fails - but I do not understand the steps that get you there - is this all in one viewport? Are you only moving the origin?

-Pascal

Hi Pascal,

This problem happens in a fresh open of Rhino 6.

If I go to either the ‘Top’ or ‘Right’ viewports and type CPlane -> All=Yes and then click to move the CPlane origin, then the axes of the CPlane will appear to flip. I am used to a local X-Y CPlane for each viewport, with the Perspective CPlane being the Top View CPlane.

Oddly enough, when I change the CPlane origin in either Perspective or Front views, it behaves as normal.

Hi Evan - can you run SystemInfo in Rhino and post the results? this is ringing a faint bell (the only kind I get these days) from an earlier service release’s problem…

-Pascal

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: LAN Zoo Network Node

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: AB-PC3

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 760 Ti OEM (NVidia) Memory: 2GB, Driver date: 4-9-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 425.31

Secondary graphics devices.
Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 8-16-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-9-2019
Driver Version: 25.21.14.2531
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Hi Evan - you are behind - current is SR 16 -

https://www.rhino3d.com/download/rhino-for-windows/6/latest

Try that and see if things look better.

-Pascal

It works now. Quite frustrating. The resolution to this question also resolves CPlane not appearing in Top or Right views this post.

Thank you.

Hi Evan - meaning, I hope, that installing the later SR sorted it out?

-Pascal

Yes.