Delete mass from revit

I used in the base code of import rhino to revit in the website page.
now i want delet this mass from revit. how can do it?


There is a delete component, you can also unpin and delete manually if need be.

1 Like

how i can unpin?
now the mass appear only in revit and i can’t chose it, It’s like frozen…

thanks so much!

there is also an unpin component, or right click on the output and there is a unpin option.

1 Like

its not working. the mass still frozen. The vaults marked with an arrow:

@yehmerm Would you be able to share screenshots or files so we can see what you are looking at?

Well, nothing worked for me and I transferred the file to a new file revit without the mass.
Can someone send me an updated transfer gh file from rhino to revit that work without problem?

Guess the whole model is one direct shape. If you graft the output before it gets to the direct shape component, each object will be its own in Revit.

But it you put you definition here we can check that.

10-1 model .rvt (6.0 MB)
this the revit file.
you can send me a new file of transfer?

@yehmerm I’m still not sure what the issue is. Please be more specific and share screenshots, Grasshopper files or other resources so we can replicate the issue here. I opened the Revit model you shared and I can easily delete the mass either manually or thru a grasshopper definition.

If you are seeing an error in the Grasshopper definition, make sure the delete is the last step in the process and the element being deleted is not used or modified in other places in the definition

If you select the Vaults in your model, there is the pin icon that you click on to disable. Then Delete it.

Keep it Pinned if you want Grasshopper to continue to replace it as you change the Vaults in Grasshoppers?

1 Like