Cycles looking good, takes too long to render draft quality


#1

Cycles is looking good thanks for the hard work on that. The only thing is that it takes too long to render an image in the viewport at draft quality I would expect this to take at most 2 minutes not 12 minutes with the simple scene I was working on.
RM


(Brian James) #2

The Quality drop down menu in the Rendering panel refers to the sampling level and anti-aliasing used when you use the Render command. The quality of the Raytraced viewport however is controlled by the sample value set in the lower right corner of the viewport when Raytraced is active. You can click this number to change the sample target. You can also change the sample target for Raytraced mode in Options>Rhino Options>Cycles. Of course the viewport pixel size, render meshes, materials and lighting and what devices are calculating Raytraced are also all factors. If you think something is too slow to get to a certain sample count, please post the 3dm as well as the pixel size of the viewport being used, sample count set and what compute devices you’re using. Thanks!


(Nathan 'jesterKing' Letwory) #3

Also note that changing Cycles sampling settings is done through Tools > Options > Cycles. Here you can change bounce-related settings as well.


#4

Compared to other rendering engines, on draft quality, cycles is slow.


(Nathan 'jesterKing' Letwory) #5

Raytraced/Cycles doesn’t use the render quality menu, as was already mentioned.


#6

hi @nathanletwory

Will it have predefined settings in the future, to choose from? I always switch back and forward from Low to High to Low again, in Vray.


(Nathan 'jesterKing' Letwory) #7

At some point there will be predefined settings yes.


#8

Seems like a lot of locations to keep in mind. Couldn’t it all be controlled by the setting for Drafts, etc. …