Render Viewport Slow selected Cylces

cycles

#1

Using (6.0.17220.11131, 2017/08/08) and the render viewport when Cycles is selected is very slow…
Is there a way to speed up a bit by lowering the quality?

In Blender Cycles I recall setting for reducing samples, raytracing just for the rendered view to get a quick preview.

I’m running on laptop so I know it’s not going to be super fast but was expecting a little better.
Running on Corei7 7700HQ 2.8GHz, 16GB and
GTX1050


#2

Toshiaki_Takano - your laptop as described SHOULD be giving you acceptable performance. Any improvements recently ?


#3

Just installed the V6 for different purpose, so first time using cycles in Rhino.
Hmm… Maybe I’ll setup blender cycles and see…
I also don’t see transparent material in the viewport…

(tried to capture video screenshot, but was like 50MB)

Anyway, I’m just having a sphere, square, and a simple revolved surface with
Blur environment. Material being: Sphere: metal Square: paint Revolved surface: glass.
Just gumball dragging with mouse is slow. There’s like a 0,5sec delay in movement.
Also changing to different viewport like Top,Left is also slow.


#4

New version released. I’ll check that one.


(Nathan 'jesterKing' Letwory) #5

You can adjust settings through Tools > Options > Cycles.

You can do even more advanced settings through Tools > Options > Advanced. Type in RhinoCycles to filter for all Cycles-related settings.

Object changes like dragging with gumball may take a while, especially if you are on a 4K screen.

It takes a while for Cycles to drop its current sample. I haven’t found a good solution yet to have it instantly abort mid-sample.


#7

The transparent objects now ok with (6.0.17227.14151, 2017/08/15)
Viewport render speed is same…

In the advanced setting of rhino could you help me to locate similar setting item as preview sampling number in blender?Setting as below.
I’m thinking I can lower this to like 2 samples for preview.
Though curretly in the viewport it doesn’t seem to do any sampling,
I mean it doesn’t see to get cleaner/sharper.

image

One other general question @nathanletwory, When I switch from Cycles render to Rhino render, I don’t see
much difference in the viewport. Is there anything I need to do to switch or is it actually changed?

It might be better if I can move things around using similar performance as
V5 Rhino Render in the rendering viewport, then switch to Cycles with low sampling number, then go for the actual render when all is set.


(Nathan 'jesterKing' Letwory) #8

Cycles settings in Options dialog.

RhinoCycles advanced options (note I typed RhinoCycles in the filter text box)