Simple Scene: Render quality

Hi,

Here is a simple scene with a Cube (Red Paint: 50% reflective) and and HDRI Light and a gradient ground plane. Render Quality set to good.
Am I missing a setting here as the render quality is not that great ?

See screenrecording.

How do you mean when you say render quality is not good?
Do you mean the jagged lines?
800×600 maybe a bit small…

Here is the image generated.
Anti-aliasing looks ok to me. This is what strikes me.

  1. The image is quite noisy.
  2. The top surface appears quite saturated compared to the Viewport display in Render mode
  3. Overall the light gradients across the surfaces appear more basic (less rich than viewport).

One is you can change the HDRI to something more dramatic than the default studio.
Other is using cycles to render would provide better rendering.
For the BETA, there’s no render window for cycles, you can set viewport to raytraced and save the rendering by viewcapturetofile
it’ll do the render, no progress preview, but save it
as a file.

Or does turning on
utilize custom reflection help?

Here’s what I get from a similar test scene- seems pretty close, considering the completely different system used to render each…

-Pascal

@Toshiaki_Takano, yes it does help to set the “object” lections to be based on the HDRI.
I get pretty similar results to what @pascal is showing.

btw – I applied the Startup HDRI which comes with Keyshot. The results are not much better I am afraid (Final quality setting). Still quite noisy. See below.

I am still hoping I am missing some controls here :wink: So that I can help my students improve on renders using the default render engine.

I know RhinoCycles will become an option down the road and will be getting some of these very sweet things such as Noise reduction, branched path, Filmic deployed in blender 2.79…

Cycles is already available as the viewport mode Raytraced. Denoising and filmic will come later in the future. Branched path tracing already should, but to be honest I haven’t tested that in a loooong time, mainly because it isn’t as responsive in the viewport as I’d like it to be.

Is cycles only in Raytraced Mode available? What about the renderengine? As i played with the renderer it feels very CPU based… or am i wrong?

Raytraced is the Cycles render engine. But instead of rendering to a modal render window it shows the Cycles progressive rendering interactively in the viewport. If you have a CUDA card (NVidia) that is at least built on the Fermi GPU architecture or newer you can find that it is preselected in the Tools > Options > Cycles section. In that case GPU rendering is used. If you don’t have a CUDA GPU then CPU is used (AMD cards can be used too, but there is a performance problem with those that I am still trying to get solved).

There are few things you can tweak I think already with advanced settings in properties.
@nathanletwory does this apply to rhino cycles?

Just thought I would mention I am using AMD Radeon pro 580 which is supplied with my iMac late 2017 edition. I am running under boot camp latest’s drivers installed, Ray trace does not start just sits on rendering… dose not show a count or timer like it does when I am rendering using CPU. I do not have this issue in blender 2.79 renders correctly using the AMD card.

I am aware of the problems with AMD cards. I have an AMD RX 550 in my machine, and it is very slow in Raytraced. I am investigating. Until I find a solution you best use CPU for rendering. If it sits there with Rendering... in the HUD then the OpenCL kernels are probably still being compiled. You can check %APPDATA%\McNeel\Rhinoceros\6.0\Plug-ins\RhinoCycles (9bc28e9e-7a6c-4b8f-a0c6-3d05e02d1b97)\data\cache\kernels to see if it contains a set of *.clbin files.

/Nathan

p.s. I use Blender daily to test and compare.

The same with my RX460 on my home PC. Raytraced just never even stars. It’s been like that for quite a while. Luckily not a problem for me since I don’t use that system for actual work.
Anyway I hope @nathanletwory finds a solution soon. Supporting OpenCL instead of cuda-only is one of the big advantages of cycles. Also without AMD support about all MAC users are left out. This month the new pro-macs with vega will be available - would be a shame if that card would have to wait for support.

I’m looking as we speak, during the weekend…

1 Like