Cycles black viewport

unhandled

#1

I have an older notebook here.
NVidia Geforce G210M
OpenGL 3.3.0
Driver version 342.01, fresh install
Win10/64 1803, fresh install
Rhino6, fresh install

Switching to Raytraced in a viewport only gives a black area.
I can see Cycles working, also the taskmager show corresponding activity.

In the settings, Cycles uses CPU not GPU.
This is the default after Rhino6 installation.

What can be wrong?


(Nathan 'jesterKing' Letwory) #2

Your OpenGL driver says version 3.3.0. The theory is that Cycles then automatically uses a mechanism for drawing that does not include OpenGL, but it looks like that isn’t happening. I have logged that as RH-47222.

Until then you can set the advanced option UseDrawOpenGl to false, restart Rhino and then use Raytraced.

image


#3

Nathan, you do realtime support.

Works.
Even without restarting Rhino…

Thank you.


(Nathan 'jesterKing' Letwory) #4

Mind blown :open_mouth: Good it works though :slight_smile:


#5

Remark:
This seems to be a per user setting.
I logged into another account on that PC, and the setting was not there.

No, problem, I know how to switch it now :grinning:


(Nathan 'jesterKing' Letwory) #6

I have made a fix for this. It should be available in the next 6.7 release candidate sometime next week Tuesday/Wednesday.