Raytraced viewport rotation shows bg color


#1

Hi Nathan,
Glad it’s working for someone. This is what I was suggesting you do unfortunately it’s not working for me, I just installed the latest wip.
I tried all numbers in advanced options under FadeInMs and I never see any thing but white when I pan or rotate the viewport as I said in my last post this makes Cycles completely unusable for me.
Also I can get Rhino to lock completely using cycles in one file I have, it seems turning on cycles then options locks Rhino in this one file, rhino doesn’t crash just sits there no matter how long I leave it, I then have to terminate from the task manager . I think it might be a light issue with a texture I’ll look into that.

I’m in win 10,
Here’s my video card specs,
Thanks for your hard work on this,
RM
NVIDIA System Information 06-06-2016 17-30-04.txt (3.5 KB)


Raytraced viewport movement is awesome!
#2

Same here.

Video hardware & driver information
NVIDIA Corporation
Quadro M2000M/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 354.25
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 9-28-2015
Driver Version: 10.18.13.5425

Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB


(Nathan 'jesterKing' Letwory) #3

I’ll have to get access to similar hardware then. Thanks for reporting.

Edit: actually, could you (@3dsynergy and @siemen) please attach the output of RhinoCycles_ShowDeviceCapabilities for me? Thank you.


(Nathan 'jesterKing' Letwory) #4

@3dsynergy have you tried updating your driver yet?

@siemen , you might want to update your driver too.

For both GPUs new drivers were released this month.


(Wim Dekeyser) #5

@nathanletwory, I’m also getting nothing but white on viewport manipulation here and it takes about 10 seconds before Cycles shows something - on a maximized floating viewport (1920 x 1176) for a relatively simple scene with 37 surfaces and 207 polysurfaces.

My default Raytraced mode shows surface edges with 1 px (and 99% color reduction) and these edges can be seen during viewport manipulation.

System info:

Rhino 6 SR0 2017-5-23 (Rhino WIP, 6.0.17143.8371, Git hash:master @ 39138b7e735afb3423d426c98f93128498372e6f)

Windows 7 SP1 (Physical RAM: 31Gb)

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.05)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-1-2017
Driver Version: 22.21.13.8205
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Output of RhinoCycles_ShowDeviceCapabilities attached:
RhinoCycles_GPUCapabilities-wd.txt (4.9 KB)


(Nathan 'jesterKing' Letwory) #6

Hrm,

not sure why viewport would be white during viewport manipulation. Does the viewport color on rotation correspond to the setting of solid bg color in rendering settings? I.e. change it to green, does viewport show up as green only on rotation?

/Nathan


(Wim Dekeyser) #7

Sorry about that one :blush:
Yes.


Also…
Is there some way to render what’s above the GroundPlane when looking from beneath it?


(Nathan 'jesterKing' Letwory) #8

If you rotate really slowly, does the opengl rendering catch up and start showing?

Probably, separate issue from the errors though :slight_smile:


(Wim Dekeyser) #9

I don’t think so, but I’m not sure what that looks like, I suppose…
Here’s a screen recording (zipped as Discourse doesn’t like wmv).
2017–05-26 Raytraced.zip (780.7 KB)


(Nathan 'jesterKing' Letwory) #10

Just to rule out white on white not being terribly visible, could you please assign a non-white material to your cube, rerecord and attach Yet Another Great Movie?

Thanks,

/Nathan


(Wim Dekeyser) #11

One green YAGM coming up!
2017–05-26 Raytraced-green.zip (864.8 KB)

Let me know if you want me to do this on a “real” scene (as opposed to a simple box).


(Nathan 'jesterKing' Letwory) #12

I kinda asked the other way around (green box on white bg), but this YAGM works just fine (:

No need. It happens for you on simple scene, which is for me the best thing. Fewer moving parts that could cause Errors.

Now I need to figure out why on some cards there is no proper OpenGL rendering :confused:


#13

Hi Nathan,
I’ve attached an image of my current driver should I update it looks new?

I have two video cards in my laptop but I have the NVidia set in it’s settings to use rhino don’t know if that will help, thought I’d mention it.


#14

Hmmm. The white screen on rotate is happening to me on my home computer, but not on my work computer. Weird.

OK, well, I went into Rhino Options>View>Display Modes>Raytraced and click the Restore Defaults button, and it fixed it for me.


(Nathan 'jesterKing' Letwory) #15

Cool, hadn’t thought of that. @wim, @3dsynergy, before you reset to defaults could you please send me your settings XML file from %APPDATA%\McNeel\Rhinoceros\6.0\settings(I don’t need the window position XML). I’d like to see the settings you had, especially if reset works. Also resetting the Cycles settings could be a thing to try…

Thanks all,

/Nathan


(Wim Dekeyser) #16

@nathanletwory, resetting to defaults works here as well…
Here’s my xml file from before the reset.
2017-05-27 wd-settings-Scheme__Default.xml (116.3 KB)

HTH,
w

EDIT:
I see that the reset is per page and I only reset the … > Objects > Surfaces page.


(Nathan 'jesterKing' Letwory) #17

Thanks. It’ll give me some idea of what causes this. I hope that for @3dsynergy the reset works too.

I noticed that switching display modes with the display properties panel open triggers profile saves. This also means that this saves Raytraced settings even though nothing for it has changed. I found this a few days ago. I think this behavior results in this kind of undesirable effects. I created s YouTrack issue for the saving on switching, but I think more issues are needed to get this perfect.


#18

Here’s the file you asked for I haven’t reset yet.
RM
settings-Scheme__Default.xml (92.9 KB)


#19

I reset and now it’s working here too.
Hope the files helped.
Thanks for your hard work cycles is really working nice now. I’m finally getting shadows too which I haven’t been all these wips. There must be something in that reset.
RM


(Nathan 'jesterKing' Letwory) #20

Cool. I am glad this all now works. Indeed it is possible to globally turn off shadows. That is probably what had happened.

I’ll be investigating the files on Monday.

Thanks all,

/Nathan